summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-mathematics/yafu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-mathematics/yafu')
-rw-r--r--sci-mathematics/yafu/Manifest1
-rw-r--r--sci-mathematics/yafu/files/fix-Makefile.patch11
-rw-r--r--sci-mathematics/yafu/metadata.xml11
-rw-r--r--sci-mathematics/yafu/yafu-1.34.3.ebuild56
-rw-r--r--sci-mathematics/yafu/yafu-9999.ebuild56
5 files changed, 135 insertions, 0 deletions
diff --git a/sci-mathematics/yafu/Manifest b/sci-mathematics/yafu/Manifest
new file mode 100644
index 000000000000..e6c96aed4607
--- /dev/null
+++ b/sci-mathematics/yafu/Manifest
@@ -0,0 +1 @@
+DIST yafu-1.34-src.zip 686655 SHA256 ad3e6b74f766a7c59280642065ea9482d438dc3be383962f50119f43948631be SHA512 f8afba77e0286c579b4152517ba3a0b6b85d43606e4fafc653dc06b7f7c2aba0f8f3c65b38f3496657495bff476dd4cc8e06daaad8a7a78a36fc6e1c0cf046a4 WHIRLPOOL 69a2b0a99914bbf3cbb6b0cc91597b3d9ae25f29622af859a279f53c2281ae5e0f4e691112f111ad53781b0fe0258f73b1c9ee400cb4d22c28cfeb136785ca41
diff --git a/sci-mathematics/yafu/files/fix-Makefile.patch b/sci-mathematics/yafu/files/fix-Makefile.patch
new file mode 100644
index 000000000000..82b8e0d7d2ff
--- /dev/null
+++ b/sci-mathematics/yafu/files/fix-Makefile.patch
@@ -0,0 +1,11 @@
+--- Makefile.orig 2013-03-17 11:20:40.248683894 +0400
++++ Makefile 2013-03-17 11:20:47.352683657 +0400
+@@ -87,7 +87,7 @@ ifeq ($(CC),icc)
+ CFLAGS += -mtune=core2 -march=core2
+ endif
+
+-LIBS += -lecm -lgmp
++LIBS += -lecm -lgmp -lgomp
+
+ CFLAGS += $(OPT_FLAGS) $(WARN_FLAGS) $(INC)
+
diff --git a/sci-mathematics/yafu/metadata.xml b/sci-mathematics/yafu/metadata.xml
new file mode 100644
index 000000000000..0bc3be1ea5ed
--- /dev/null
+++ b/sci-mathematics/yafu/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+ <use>
+ <flag name="sieve">Use msieve for the sieving steps of NFS</flag>
+ </use>
+</pkgmetadata>
diff --git a/sci-mathematics/yafu/yafu-1.34.3.ebuild b/sci-mathematics/yafu/yafu-1.34.3.ebuild
new file mode 100644
index 000000000000..49dce30f425d
--- /dev/null
+++ b/sci-mathematics/yafu/yafu-1.34.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils versionator
+
+MY_PV="$(get_version_component_range 1-2)"
+
+DESCRIPTION="Yet another factoring utility"
+HOMEPAGE="http://sourceforge.net/projects/yafu/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PV}/${PN}-${MY_PV}-src.zip"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+# nfs is overloaded, so using less confusing sieve here
+IUSE="+sieve"
+
+DEPEND="
+ dev-libs/gmp
+ sci-mathematics/gmp-ecm
+ sieve? (
+ sci-mathematics/msieve
+ sci-mathematics/ggnfs )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix-Makefile.patch"
+ # This is not nice. But then the Makefile is quite special :)
+ sed -i -e 's:../gmp/include:gmp:' Makefile || die "Failed to rectify things"
+ sed -i -e 's:../gmp-ecm/include:gmp-ecm:' Makefile || die "Failed to rectify things"
+ sed -i -e 's:LIBS += -L../:# LIBS += -L../:g' Makefile || die "Failed to rectify things"
+ sed -i -e 's:\"config.h\":<gmp-ecm/config.h>:g' top/driver.c || die "Failed to rectify things"
+ sed -i -e 's:# LIBS += -L../msieve/lib/linux/x86_64:LIBS += -lmsieve -lz -ldl:' Makefile || die "Failed to rectify things"
+ sed -i -e 's:CFLAGS = -g:#CFLAGS = -g:' Makefile || die "Failed to rectify things"
+ sed -i -e '/$(LIBS)$/s:$(CC):$(CC) $(LDFLAGS):g' Makefile || die
+
+ # proper ggnfs default path
+ sed -i -e 's~strcpy(fobj->nfs_obj.ggnfs_dir,"./");~strcpy(fobj->nfs_obj.ggnfs_dir,"/usr/bin/");~' factor/factor_common.c || die "Failed to rectify things"
+}
+
+src_compile() {
+ local VAR=""
+ # hmm, not that useful:
+ #VAR="TIMING=1 "
+ use sieve && VAR+="NFS=1"
+ use amd64 && emake $VAR x86_64
+ use x86 && emake $VAR x86
+}
+
+src_install() {
+ dobin "${S}/yafu"
+ dodoc docfile.txt README yafu.ini
+}
diff --git a/sci-mathematics/yafu/yafu-9999.ebuild b/sci-mathematics/yafu/yafu-9999.ebuild
new file mode 100644
index 000000000000..f19d80fb8b5f
--- /dev/null
+++ b/sci-mathematics/yafu/yafu-9999.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils subversion versionator
+
+DESCRIPTION="Yet another factoring utility"
+HOMEPAGE="http://sourceforge.net/projects/yafu/"
+#SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+ESVN_REPO_URI="https://svn.code.sf.net/p/yafu/code/"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS=""
+# nfs is overloaded, so using less confusing sieve here
+IUSE="+sieve"
+
+DEPEND="
+ dev-libs/gmp
+ sci-mathematics/gmp-ecm
+ sieve? (
+ sci-mathematics/msieve
+ sci-mathematics/ggnfs )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cd trunk
+ # This is not nice. But then the Makefile is quite special :)
+ sed -i -e 's:../gmp/include:gmp:' Makefile || die "Failed to rectify things"
+ sed -i -e 's:../gmp-ecm/include:gmp-ecm:' Makefile || die "Failed to rectify things"
+ sed -i -e 's:LIBS += -L../:# LIBS += -L../:g' Makefile || die "Failed to rectify things"
+ sed -i -e 's:\"config.h\":<gmp-ecm/config.h>:g' top/driver.c || die "Failed to rectify things"
+ sed -i -e 's:# LIBS += -L../msieve/lib/linux/x86_64:LIBS += -lmsieve -lz -ldl:' Makefile || die "Failed to rectify things"
+ sed -i -e 's:CFLAGS = -g:#CFLAGS = -g:' Makefile || die "Failed to rectify things"
+ sed -i -e '/$(LIBS)$/s:$(CC):$(CC) $(LDFLAGS):g' Makefile || die
+
+ # proper ggnfs default path
+ sed -i -e 's~strcpy(fobj->nfs_obj.ggnfs_dir,"./");~strcpy(fobj->nfs_obj.ggnfs_dir,"/usr/bin/");~' factor/factor_common.c || die "Failed to rectify things"
+}
+
+src_compile() {
+ local VAR=""
+ cd trunk
+ # hmm, not that useful:
+ #VAR="TIMING=1 "
+ use sieve && VAR+="NFS=1"
+ use amd64 && emake $VAR x86_64
+ use x86 && emake $VAR x86
+}
+
+src_install() {
+ dobin "${S}/yafu"
+ dodoc docfile.txt README yafu.ini
+}