summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2023-02-25 16:22:48 +0100
committerSam James <sam@gentoo.org>2023-02-25 22:23:26 +0000
commit9228197421b2462c1b6bbf66c47781f241b83db7 (patch)
tree04eb6b068bdc91eb962c84a4b436d637934b42ce /sci-physics/hepmc
parentdev-python/leechcorepyc: add 2.14.0 (diff)
downloadgentoo-9228197421b2462c1b6bbf66c47781f241b83db7.tar.gz
gentoo-9228197421b2462c1b6bbf66c47781f241b83db7.tar.bz2
gentoo-9228197421b2462c1b6bbf66c47781f241b83db7.zip
sci-physics/hepmc: add 3.2.5_p20230225
Closes: https://bugs.gentoo.org/897238 Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-physics/hepmc')
-rw-r--r--sci-physics/hepmc/Manifest1
-rw-r--r--sci-physics/hepmc/hepmc-3.2.5_p20230225.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sci-physics/hepmc/Manifest b/sci-physics/hepmc/Manifest
index 80795b1f230c..ba98b1642ec6 100644
--- a/sci-physics/hepmc/Manifest
+++ b/sci-physics/hepmc/Manifest
@@ -1,3 +1,4 @@
DIST HepMC-2.06.09.tar.gz 4612637 BLAKE2B 6bbf1a6a8410b6717ddff29fc3643247582f7a61a05fd9e52a0b09f78bf75de587c1c55525f6a1367b306a26a4687ce55b64908c049d91bdb2db3d40467af62b SHA512 1030f31ad9d19d8ae184145a693c4a3092131f485e2ed89598b7172992a825ad9aa46fb44a9199a00c4a6bd7e163daead9452e9bc4fe32cb3b97351cf22906c4
DIST HepMC3-3.2.5.tar.gz 9217649 BLAKE2B 520e4621cdfa277376e94b87a070f23e6479867bbf696dc972e7496c54504c7da921932fbeaf7713cbaab18c72101ad3fa79396fe8ee1737180946696dcd1fbd SHA512 de60aaa686f6499c62112c265438b9ba41a7ed312b767ddc3409178b6e908e4fffd6a1153bd9f2929cf479074b14bcbec33d377f51a11cfcd4c67e45fc9bb2b9
+DIST HepMC3-e05d32ebac8705c0097e9e7d00ce815a205110db.tar.gz 9346161 BLAKE2B 9304d329332c2d4eb0ef6526a3308aecd29a38c569d3ba57d94767fd38ad052514f75a7a90f301c54185230d7693a67e48d59b66b12f42626a7ef900e309f743 SHA512 45f9edc6c56f9f8494b416bff147dccca64c52a90e0e169ede560ae8cf9e9255258b7af1586dd1c856f4010c22b2e668511bab160487a3ba802b629d03015e55
DIST hepmc2.06.11.tgz 4893958 BLAKE2B ac8eef250cb330a167c9e0f4bd1aaf8df82e0ffec3557ab5cdaf8bc5b0b7333d6a45f73710ce63abab52d2c5758d5663c15c2a7c940a09504b3ef2fd4517aa0b SHA512 81c100d4931e0e4de62c8ffd18cc06e7996a642fecc092892988bdc0dd0dc3c0f5b336e85f09ceb8f5e0e09456775ae5928d37daf28d82923476089bc0e910f2
diff --git a/sci-physics/hepmc/hepmc-3.2.5_p20230225.ebuild b/sci-physics/hepmc/hepmc-3.2.5_p20230225.ebuild
new file mode 100644
index 000000000000..4f6201190a03
--- /dev/null
+++ b/sci-physics/hepmc/hepmc-3.2.5_p20230225.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit cmake python-single-r1
+
+MYPN=HepMC3
+MYP=${MYPN}-${PV}
+
+DESCRIPTION="Event Record for Monte Carlo Generators"
+HOMEPAGE="https://hepmc.web.cern.ch/hepmc/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.cern.ch/hepmc/HepMC3"
+else
+ COMMIT="e05d32ebac8705c0097e9e7d00ce815a205110db"
+ SRC_URI="https://gitlab.cern.ch/${PN}/${MYPN}/-/archive/${COMMIT}/${MYPN}-${COMMIT}.tar.gz"
+ S="${WORKDIR}/${MYPN}-${COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="3"
+IUSE="doc test examples python root"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ root? ( sci-physics/root:= )
+ doc? (
+ app-doc/doxygen[dot]
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-latexrecommended
+ )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DHEPMC3_ENABLE_ROOTIO=$(usex root ON OFF)
+ -DHEPMC3_ENABLE_PYTHON=$(usex python ON OFF)
+ -DHEPMC3_ENABLE_TEST=$(usex test ON OFF)
+ -DHEPMC3_BUILD_DOCS=$(usex doc ON OFF)
+ -DHEPMC3_BUILD_EXAMPLES=$(usex examples ON OFF)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ use examples && docompress -x /usr/share/doc/${PF}/examples
+ python_optimize
+}