summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-19 23:36:31 +0000
committerSam James <sam@gentoo.org>2022-11-19 23:37:08 +0000
commitfaa75d431684f8efcebf1116128ae3e528d0889a (patch)
tree1e2936fef9d89dd0cdd050b0363299fbf795b712 /sys-apps/file
parentmail-filter/spamassassin: fix configure w/ clang 16 (diff)
downloadgentoo-faa75d431684f8efcebf1116128ae3e528d0889a.tar.gz
gentoo-faa75d431684f8efcebf1116128ae3e528d0889a.tar.bz2
gentoo-faa75d431684f8efcebf1116128ae3e528d0889a.zip
sys-apps/file: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/file-5.43-r1.ebuild (renamed from sys-apps/file/file-5.43.ebuild)1
-rw-r--r--sys-apps/file/files/file-5.43-configure-clang16.patch20
2 files changed, 21 insertions, 0 deletions
diff --git a/sys-apps/file/file-5.43.ebuild b/sys-apps/file/file-5.43-r1.ebuild
index 7a43ed771918..10bf50a18e4f 100644
--- a/sys-apps/file/file-5.43.ebuild
+++ b/sys-apps/file/file-5.43-r1.ebuild
@@ -51,6 +51,7 @@ BDEPEND+="
PATCHES=(
"${FILESDIR}/file-5.39-portage-sandbox.patch" #713710 #728978
"${FILESDIR}/file-5.40-seccomp-fstatat64-musl.patch" #789336, not upstream yet
+ "${FILESDIR}/${P}-configure-clang16.patch"
)
src_prepare() {
diff --git a/sys-apps/file/files/file-5.43-configure-clang16.patch b/sys-apps/file/files/file-5.43-configure-clang16.patch
new file mode 100644
index 000000000000..15fd5b1c4a05
--- /dev/null
+++ b/sys-apps/file/files/file-5.43-configure-clang16.patch
@@ -0,0 +1,20 @@
+https://github.com/file/file/commit/4502517cc7316569d5902ab65c97b3b8e46f8a25
+https://github.com/file/file/commit/8c845b7bbad085678695d3e70467b8eec3dfa7af
+--- a/configure
++++ b/configure
+@@ -14037,13 +14037,14 @@ else $as_nop
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ #include <time.h>
++#include <stdlib.h>
+ int
+ main (void)
+ {
+ #if !HAVE_DECL_DAYLIGHT
+ extern int daylight;
+ #endif
+-atoi(daylight);
++daylight = atoi("1");
+ ;
+ return 0;
+ }