summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-27 10:14:55 +0100
committerSam James <sam@gentoo.org>2022-06-27 10:27:04 +0100
commit303a746c9ffce9f5940f48ffef8f1cd30ae968ee (patch)
tree2df97c10f72bc1e6be8ecd6397983776f1abfbed /sys-apps/lm-sensors
parentgames-misc/opensfx: fix build w/o sys-apps/which (diff)
downloadgentoo-303a746c9ffce9f5940f48ffef8f1cd30ae968ee.tar.gz
gentoo-303a746c9ffce9f5940f48ffef8f1cd30ae968ee.tar.bz2
gentoo-303a746c9ffce9f5940f48ffef8f1cd30ae968ee.zip
sys-apps/lm-sensors: fix build w/o sys-apps/which
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/lm-sensors')
-rw-r--r--sys-apps/lm-sensors/files/lm-sensors-3.6.0-no-which.patch21
-rw-r--r--sys-apps/lm-sensors/lm-sensors-3.6.0.ebuild5
2 files changed, 25 insertions, 1 deletions
diff --git a/sys-apps/lm-sensors/files/lm-sensors-3.6.0-no-which.patch b/sys-apps/lm-sensors/files/lm-sensors-3.6.0-no-which.patch
new file mode 100644
index 000000000000..e75e23142d86
--- /dev/null
+++ b/sys-apps/lm-sensors/files/lm-sensors-3.6.0-no-which.patch
@@ -0,0 +1,21 @@
+https://github.com/lm-sensors/lm-sensors/pull/402
+--- a/Makefile
++++ b/Makefile
+@@ -250,7 +250,7 @@ manhtml:
+
+ # Flex and Bison
+ %.c: %.y
+- @if ! which $(BISON) 2> /dev/null ; then \
++ @if ! command -v $(BISON) 2> /dev/null ; then \
+ echo "Please install $(BISON), then run \"make clean\" and try again" ; \
+ false ; \
+ fi
+@@ -263,7 +263,7 @@ FLEX_FLAGS := -Psensors_yy -t -Cfe -8
+ endif
+
+ %.c: %.l
+- @if ! which $(FLEX) 2> /dev/null ; then \
++ @if ! command -v $(FLEX) 2> /dev/null ; then \
+ echo "Please install $(FLEX), then run \"make clean\" and try again" ; \
+ false ; \
+ fi
diff --git a/sys-apps/lm-sensors/lm-sensors-3.6.0.ebuild b/sys-apps/lm-sensors/lm-sensors-3.6.0.ebuild
index 74b209916ec0..01d6dec1eb38 100644
--- a/sys-apps/lm-sensors/lm-sensors-3.6.0.ebuild
+++ b/sys-apps/lm-sensors/lm-sensors-3.6.0.ebuild
@@ -44,7 +44,10 @@ WARNING_HWMON="${PN} requires CONFIG_HWMON to be enabled for use."
WARNING_I2C_CHARDEV="sensors-detect requires CONFIG_I2C_CHARDEV to be enabled."
WARNING_I2C="${PN} requires CONFIG_I2C to be enabled for most sensors."
-PATCHES=( "${FILESDIR}"/${PN}-3.5.0-sensors-detect-gentoo.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.5.0-sensors-detect-gentoo.patch
+ "${FILESDIR}"/${PN}-3.6.0-no-which.patch
+)
DOCS=( CHANGES CONTRIBUTORS INSTALL README )
DOCS+=( doc/{donations,fancontrol.txt,fan-divisors,libsensors-API.txt,progs,temperature-sensors,vid} )