summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-01 22:10:46 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-01 22:18:16 +0000
commit5050debfedd9ef939113ab1c2e3f0de3be6e15c0 (patch)
tree559560b651a4a7112240d6869e845c302bda47f7 /sys-apps/nix
parentmedia-plugins/kodi-pvr-mythtv: Depend on the correct versions of kodi (diff)
downloadgentoo-5050debfedd9ef939113ab1c2e3f0de3be6e15c0.tar.gz
gentoo-5050debfedd9ef939113ab1c2e3f0de3be6e15c0.tar.bz2
gentoo-5050debfedd9ef939113ab1c2e3f0de3be6e15c0.zip
sys-apps/nix: don't hardcode UID/GID for nix internal groups
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-apps/nix')
-rw-r--r--sys-apps/nix/nix-1.11.6-r1.ebuild114
-rw-r--r--sys-apps/nix/nix-1.11.6-r3.ebuild (renamed from sys-apps/nix/nix-1.11.6-r2.ebuild)4
2 files changed, 2 insertions, 116 deletions
diff --git a/sys-apps/nix/nix-1.11.6-r1.ebuild b/sys-apps/nix/nix-1.11.6-r1.ebuild
deleted file mode 100644
index 4553ec6ee6f9..000000000000
--- a/sys-apps/nix/nix-1.11.6-r1.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit readme.gentoo-r1 user
-
-DESCRIPTION="A purely functional package manager"
-HOMEPAGE="https://nixos.org/nix"
-
-SRC_URI="http://nixos.org/releases/${PN}/${P}/${P}.tar.xz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+etc_profile +gc doc sodium"
-
-RDEPEND="
- app-arch/bzip2
- app-arch/xz-utils
- dev-db/sqlite
- dev-libs/openssl:0=
- net-misc/curl
- sys-libs/zlib
- gc? ( dev-libs/boehm-gc )
- doc? ( dev-libs/libxml2
- dev-libs/libxslt
- app-text/docbook-xsl-stylesheets
- )
- sodium? ( dev-libs/libsodium )
- dev-lang/perl:=
- dev-perl/DBD-SQLite
- dev-perl/WWW-Curl
- dev-perl/DBI
-"
-DEPEND="${RDEPEND}
- >=sys-devel/bison-2.6
- >=sys-devel/flex-2.5.35
- virtual/perl-ExtUtils-ParseXS
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-systemd.patch
- "${FILESDIR}"/${P}-per-user.patch
-)
-
-DISABLE_AUTOFORMATTING=yes
-DOC_CONTENTS=" Quick start user guide on Gentoo:
-
-[as root] enable nix-daemon service:
- [systemd] # systemctl enable nix-daemon
- [openrc] # rc-update add nix-daemon
-[as an user] relogin to get environment and profile update
-[as an user] fetch nixpkgs update:
- \$ nix-channel --update
-[as an user] install nix packages:
- \$ nix-env -i mc
-[as an user] configure environment:
- Somewhere in .bash_profile you might want to set
- LOCALE_ARCHIVE=\$HOME/.nix-profile/lib/locale/locale-archive
- but please read https://github.com/NixOS/nixpkgs/issues/21820
-
-Next steps:
- nix package manager user manual: http://nixos.org/nix/manual/
-"
-
-pkg_setup() {
- enewgroup nixbld 30000
- for i in {1..10}; do
- # we list 'nixbld' twice to
- # both assign a primary group for user
- # and add an user to /etc/group
- enewuser nixbld${i} $((30000 +$i)) -1 /var/empty nixbld,nixbld
- done
-}
-
-src_configure() {
- econf \
- --localstatedir="${EPREFIX}"/nix/var \
- $(use_enable gc)
-}
-
-src_install() {
- # TODO: emacs highlighter
- default
-
- readme.gentoo_create_doc
-
- # here we an eager variant of something that
- # is lazily done by nix-daemo and root nix-env
-
- # TODO: will need a tweak for prefix
- keepdir /nix/store
- fowners root:nixbld /nix/store
- fperms 1775 /nix/store
-
- keepdir /nix/var/nix/profiles/per-user
- fperms 1777 /nix/var/nix/profiles/per-user
-
- doenvd "${FILESDIR}"/60nix-remote-daemon
- newinitd "${FILESDIR}"/nix-daemon.initd nix-daemon
-
- if ! use etc_profile; then
- rm "${ED}"/etc/profile.d/nix.sh || die
- fi
-}
-
-pkg_postinst() {
- if ! use etc_profile; then
- ewarn "${EROOT}etc/profile.d/nix.sh was removed (due to USE=-etc_profile)."
- fi
-
- readme.gentoo_print_elog
-}
diff --git a/sys-apps/nix/nix-1.11.6-r2.ebuild b/sys-apps/nix/nix-1.11.6-r3.ebuild
index c9c976bfde56..d7eec9bc6a4e 100644
--- a/sys-apps/nix/nix-1.11.6-r2.ebuild
+++ b/sys-apps/nix/nix-1.11.6-r3.ebuild
@@ -67,12 +67,12 @@ Next steps:
"
pkg_setup() {
- enewgroup nixbld 30000
+ enewgroup nixbld
for i in {1..10}; do
# we list 'nixbld' twice to
# both assign a primary group for user
# and add an user to /etc/group
- enewuser nixbld${i} $((30000 +$i)) -1 /var/empty nixbld,nixbld
+ enewuser nixbld${i} -1 -1 /var/empty nixbld,nixbld
done
}