summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/pcsc-slb-rf72-drv/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/pcsc-slb-rf72-drv/files')
-rw-r--r--sys-apps/pcsc-slb-rf72-drv/files/pcsc-slb-rf72-drv-1.1.0-build-new.patch24
-rw-r--r--sys-apps/pcsc-slb-rf72-drv/files/pcsc-slb-rf72-drv-1.1.0-build.patch24
-rw-r--r--sys-apps/pcsc-slb-rf72-drv/files/reader.conf11
3 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/pcsc-slb-rf72-drv/files/pcsc-slb-rf72-drv-1.1.0-build-new.patch b/sys-apps/pcsc-slb-rf72-drv/files/pcsc-slb-rf72-drv-1.1.0-build-new.patch
new file mode 100644
index 000000000000..dd386b686bc8
--- /dev/null
+++ b/sys-apps/pcsc-slb-rf72-drv/files/pcsc-slb-rf72-drv-1.1.0-build-new.patch
@@ -0,0 +1,24 @@
+diff -urNp slb_rf72.org/ifdhandler.c slb_rf72/ifdhandler.c
+--- slb_rf72.org/ifdhandler.c 2001-08-23 17:19:22.000000000 +0300
++++ slb_rf72/ifdhandler.c 2006-10-07 12:57:43.000000000 +0200
+@@ -37,6 +37,7 @@
+ #ifdef HAVE_PTHREAD_H
+ #include <pthread.h>
+ #endif
++#include <openct/ctapi.h>
+
+ /*
+ * Not exported constants definition
+diff -urNp slb_rf72.org/Makefile slb_rf72/Makefile
+--- slb_rf72.org/Makefile 2001-09-05 18:22:00.000000000 +0300
++++ slb_rf72/Makefile 2006-10-07 13:05:20.000000000 +0200
+@@ -16,7 +16,7 @@ clean:
+ rm -f test *.o *.lo *.so
+
+ lib: $(OBJ)
+- $(LD) -G ifdhandler.o lib/libctapi.a -o libslb_rf72.so
++ $(CC) $(LDFLAGS) -shared `pkg-config --libs-only-L libopenct` -lopenctapi ifdhandler.o -o libslb_rf72.so
+
+ ifdhandler.o: ifdhandler.h ifdhandler.c
+- $(CC) $(CFLAGS) -c ifdhandler.c $(INCLUDES)
++ $(CC) $(CFLAGS) `pkg-config --cflags libopenct` -fPIC -DHAVE_PTHREAD_H -c ifdhandler.c $(INCLUDES)
diff --git a/sys-apps/pcsc-slb-rf72-drv/files/pcsc-slb-rf72-drv-1.1.0-build.patch b/sys-apps/pcsc-slb-rf72-drv/files/pcsc-slb-rf72-drv-1.1.0-build.patch
new file mode 100644
index 000000000000..0e6a7db2baf0
--- /dev/null
+++ b/sys-apps/pcsc-slb-rf72-drv/files/pcsc-slb-rf72-drv-1.1.0-build.patch
@@ -0,0 +1,24 @@
+diff -urNp slb_rf72.org/ifdhandler.c slb_rf72/ifdhandler.c
+--- slb_rf72.org/ifdhandler.c 2001-08-23 17:19:22.000000000 +0300
++++ slb_rf72/ifdhandler.c 2006-10-07 12:57:43.000000000 +0200
+@@ -37,6 +37,7 @@
+ #ifdef HAVE_PTHREAD_H
+ #include <pthread.h>
+ #endif
++#include <openct/ctapi.h>
+
+ /*
+ * Not exported constants definition
+diff -urNp slb_rf72.org/Makefile slb_rf72/Makefile
+--- slb_rf72.org/Makefile 2001-09-05 18:22:00.000000000 +0300
++++ slb_rf72/Makefile 2006-10-07 13:05:20.000000000 +0200
+@@ -16,7 +16,7 @@ clean:
+ rm -f test *.o *.lo *.so
+
+ lib: $(OBJ)
+- $(LD) -G ifdhandler.o lib/libctapi.a -o libslb_rf72.so
++ $(CC) -shared `pkg-config --libs-only-L libopenct` -lopenctapi ifdhandler.o -o libslb_rf72.so
+
+ ifdhandler.o: ifdhandler.h ifdhandler.c
+- $(CC) $(CFLAGS) -c ifdhandler.c $(INCLUDES)
++ $(CC) $(CFLAGS) `pkg-config --cflags libopenct` -fPIC -DHAVE_PTHREAD_H -c ifdhandler.c $(INCLUDES)
diff --git a/sys-apps/pcsc-slb-rf72-drv/files/reader.conf b/sys-apps/pcsc-slb-rf72-drv/files/reader.conf
new file mode 100644
index 000000000000..fbf7898ba65e
--- /dev/null
+++ b/sys-apps/pcsc-slb-rf72-drv/files/reader.conf
@@ -0,0 +1,11 @@
+# Configuration file for pcsc-lite
+#
+
+# Schlumberger Reflex 72 reader
+FRIENDLYNAME "Schlumberger Reflex 72"
+# Update the following to the right COM port
+DEVICENAME /dev/null
+LIBPATH %PCSC_DRIVERS_DIR%/serial/libslb_rf72.so
+CHANNELID 1
+
+# End of file