summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-26 03:52:55 +0100
committerSam James <sam@gentoo.org>2023-09-26 03:53:23 +0100
commit3dc227d1e99fa2c766297a131b212820075ba208 (patch)
tree737653a897875030e90cb6a5e66b771fe03c31d2 /sys-apps/pv
parentsec-keys/openpgp-keys-pv: new package, add 20230926 (diff)
downloadgentoo-3dc227d1e99fa2c766297a131b212820075ba208.tar.gz
gentoo-3dc227d1e99fa2c766297a131b212820075ba208.tar.bz2
gentoo-3dc227d1e99fa2c766297a131b212820075ba208.zip
sys-apps/pv: add 1.8.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/pv')
-rw-r--r--sys-apps/pv/Manifest2
-rw-r--r--sys-apps/pv/pv-1.8.0.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/pv/Manifest b/sys-apps/pv/Manifest
index 6c49a3b1162f..79ae162c4196 100644
--- a/sys-apps/pv/Manifest
+++ b/sys-apps/pv/Manifest
@@ -1,2 +1,4 @@
DIST pv-1.6.20.tar.bz2 115310 BLAKE2B b50623f623231e8e8615f960bad83d10e12d5274c57d23ea843d16fce30b3e690284b2d9b01f82a16b9790e2bf26f80f560e226589a62ca677a2cf90ea007691 SHA512 e445f91b298ed285ddab54a3f8a6b5d5297e2e2eb8ad7b2ee2cbacca4adda9c6ca2bf3c77bf2a93373d3875c5b3b0b345d3945cbd91fc2647c6c25f1661a6752
DIST pv-1.7.24.tar.gz 160435 BLAKE2B a6cff613ac99294d70d1347e78625d838873740d2251802b461a29de28d9c2dda8ebc1fd0a8807fc420c8faf846bc8afc7c6f3e551ff243f02fa5e9ab3caf53e SHA512 46310e2d297bef1a8a7cbf2a23b2e19b21e367902de6cf759fb1a58275e0351d1f6f1ae101a32acaaa579a16c18ed49b116e58f158c87be527533ebacabd7671
+DIST pv-1.8.0.tar.gz 321376 BLAKE2B b7c0cad63514d2a2254e3d0f2c3e883e958d420cd8df6b9a107c7a1fc06408f9279b8c7422bb8986772fb2755b483b8c7e9a4e18983cdec9efa077bc653f7528 SHA512 575b4ddbb23ffad9995f597595f58a92ccf9d0ff910d5fdfb513ed553238a1971c3bc09f473cabcf72fd2961ceff0b9fa0e4b8a7e06c3382e21a44551d90b7a8
+DIST pv-1.8.0.tar.gz.asc 691 BLAKE2B df0a7d58ae3ba4065a85ab922e2094064ab435ba252013ea98573993572bc14956603cc0341a3966fb867b13fb828a3a53afeea3ffc31b825d3c5f30cf6faf15 SHA512 8fb93fc4f3476f944affb839c28fd36df0adca5ef4adf69ad6604afcd117e0e3d504687992cf9113f10d7829ccda6c368f7bb901545cfe1ff170ada81d73f9ef
diff --git a/sys-apps/pv/pv-1.8.0.ebuild b/sys-apps/pv/pv-1.8.0.ebuild
new file mode 100644
index 000000000000..0f8f61567dea
--- /dev/null
+++ b/sys-apps/pv/pv-1.8.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/pv.asc
+inherit linux-info toolchain-funcs verify-sig
+
+DESCRIPTION="Pipe Viewer: a tool for monitoring the progress of data through a pipe"
+HOMEPAGE="https://www.ivarch.com/programs/pv.shtml https://codeberg.org/a-j-wood/pv"
+SRC_URI="
+ https://www.ivarch.com/programs/sources/${P}.tar.gz
+ verify-sig? ( https://www.ivarch.com/programs/sources/${P}.tar.gz.txt -> ${P}.tar.gz.asc )
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="debug nls"
+
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-pv )"
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~SYSVIPC"
+ ERROR_SYSVIPC="You will need to enable CONFIG_SYSVIPC in your kernel to use the --remote option."
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ tc-export AR
+
+ econf \
+ $(use_enable debug debugging) \
+ $(use_enable nls)
+}
+
+src_test() {
+ # -j1: https://codeberg.org/a-j-wood/pv/issues/78
+ emake -Onone check -j1
+}