summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2022-06-03 09:31:16 -0400
committerKenton Groombridge <concord@gentoo.org>2022-06-03 21:03:17 -0400
commit3b5bd65c7564355c1614a30c3d0e123aa96b40e9 (patch)
treee0eacb647a9b4289babf3baf9a73a7232e63d0ef /sys-apps/restorecond
parentsys-apps/mcstrans: bump to 3.4 (diff)
downloadgentoo-3b5bd65c7564355c1614a30c3d0e123aa96b40e9.tar.gz
gentoo-3b5bd65c7564355c1614a30c3d0e123aa96b40e9.tar.bz2
gentoo-3b5bd65c7564355c1614a30c3d0e123aa96b40e9.zip
sys-apps/restorecond: bump to 3.4
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'sys-apps/restorecond')
-rw-r--r--sys-apps/restorecond/Manifest1
-rw-r--r--sys-apps/restorecond/restorecond-3.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-apps/restorecond/Manifest b/sys-apps/restorecond/Manifest
index b14d5edab7e4..3f1999095d14 100644
--- a/sys-apps/restorecond/Manifest
+++ b/sys-apps/restorecond/Manifest
@@ -1,2 +1,3 @@
DIST restorecond-3.3.tar.gz 18970 BLAKE2B 41c0eed734ab1e89cdfd40fdb0ceff47e1c4bb66354ff78d548a9747c661fbf7ed4b6b3daa1e39325de2a2ca087aca803f073f942f3ac89b71d873e27a1d6712 SHA512 ea2b97d22c1d68aa4ea31d8850f8c9632c0db0d4d666e323c648da896554c6a6fdf6dfa3c105a1df3f1ede9da8cce5ba4c1533b05520846fcb2d584935e5d7cb
DIST restorecond-3.4-rc1.tar.gz 18961 BLAKE2B 7f5f41f9dd7e776c266818221706f5cfff2fbb3ce99550e4c679a52e1c7694ddf06a8cd686ed80787e2acbf4060bb6cb4c4c15b85eb3ee58355b560f3751e910 SHA512 5d526ceb314719400cfeecb3d28369f62ca8f29223c6eabe847f3565c27b6a7f74ef6f489750b80809df6b3227324c978e4aceca1cb2f4f6a28bcaa03f1f9db9
+DIST restorecond-3.4.tar.gz 18965 BLAKE2B a77de19d9f00d6e8f384a7ac411257b059ba3ecfefba893eda0e563600002eca705347af364d51037f8b3308bac1c5248bb9326c692175c6c1dc561b18c84bff SHA512 9c6803444445af1592a74177ba2e7cefa1b0e8e3c73d34ef932948598adb38c648dcae8495c951b1badfc587b2d67843b83598c904d924db349b6118560f115c
diff --git a/sys-apps/restorecond/restorecond-3.4.ebuild b/sys-apps/restorecond/restorecond-3.4.ebuild
new file mode 100644
index 000000000000..92cd1c69200e
--- /dev/null
+++ b/sys-apps/restorecond/restorecond-3.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit systemd toolchain-funcs
+
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Daemon to watch for creation and set default SELinux fcontexts"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/glib:2
+ >=sys-libs/libsepol-${PV}:=
+ >=sys-libs/libselinux-${PV}:="
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ SYSTEMDSYSTEMUNITDIR="$(systemd_get_systemunitdir)" \
+ SYSTEMDUSERUNITDIR=$(systemd_get_userunitdir) \
+ install
+
+ rm -rf "${D}/etc/rc.d" || die
+
+ newinitd "${FILESDIR}/restorecond.init" restorecond
+}