summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-11 08:38:43 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-11 12:33:47 +0200
commit07b9076aff8ea9bd94ef3f7713b87509f066dad8 (patch)
treef1145971dd1cf4f7a3e43828378b0b5cf1338117 /sys-apps/sandbox
parentdev-java/mockito: restrict min java to 1.8 (diff)
downloadgentoo-07b9076aff8ea9bd94ef3f7713b87509f066dad8.tar.gz
gentoo-07b9076aff8ea9bd94ef3f7713b87509f066dad8.tar.bz2
gentoo-07b9076aff8ea9bd94ef3f7713b87509f066dad8.zip
sys-apps/sandbox: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-apps/sandbox')
-rw-r--r--sys-apps/sandbox/Manifest3
-rw-r--r--sys-apps/sandbox/sandbox-2.21.ebuild74
-rw-r--r--sys-apps/sandbox/sandbox-2.22.ebuild54
-rw-r--r--sys-apps/sandbox/sandbox-2.23.ebuild54
4 files changed, 0 insertions, 185 deletions
diff --git a/sys-apps/sandbox/Manifest b/sys-apps/sandbox/Manifest
index c7d2f57bdaa0..f4b15cd33b46 100644
--- a/sys-apps/sandbox/Manifest
+++ b/sys-apps/sandbox/Manifest
@@ -1,4 +1 @@
-DIST sandbox-2.21.tar.xz 434540 BLAKE2B c9af3b44e65d96d20b98996a4b9e35cccf6b62020d49522b9fcf50b097d4ffe3719bb334405226c5ee650943bced365547a5d8b0f707ed26ef5f12a4d15dadba SHA512 42b85e230bc89d0e02f22a7ee81b4efbb2c37ff9db24982b4b39487664a095d384101b16a4689863bd32ea91349347980b1c7f8eecb09225bc65619829c6a5b2
-DIST sandbox-2.22.tar.xz 437872 BLAKE2B 248920733ffcb56422bf02711f1ae69e81a176ffb59a1a45266bb81779e2916841eee0d237be4010062693604603893973f1fb295276c25a59654dc56a2593b4 SHA512 9c83e7748aad99e14d43ad81e6f3a8d818b821467023bbb3059ce8cee248090583d31500c1278705110f1b62cad5e5bf7f23390c6548095df709521c7d842eba
-DIST sandbox-2.23.tar.xz 437980 BLAKE2B fd417ea88512e7716a7f075442f684dc67b6c7d991e4375b47de4411353abd52764e5b85709aef06d175ba492b73edf5162c03e66e456cedb8586add18c8b5ea SHA512 d25b27bfeb5f5b9a331029a453be93947f32870b84d0e11efc5bb82044de6005111959a4efef87f1055e7065f76deccce6338d44bb7ab32e3a5ec053a429dbd5
DIST sandbox-2.24.tar.xz 438408 BLAKE2B 5e725d17da0abc06d56216f4df2f4034076f50163db1c3bbddbf4fd07dbd5b7d92ef2f1b2c01eb77ff6cf531c5cc6a05e60b028f585310ac56eef96240882843 SHA512 8df5414e334a15f367acfd218ba1b74ba618b93d7bdeca8a039b69cbd81ab048ec5a6cecb24df09fa9a5f4fe214d647acf5138004defd45e6396eec5ae7c93d0
diff --git a/sys-apps/sandbox/sandbox-2.21.ebuild b/sys-apps/sandbox/sandbox-2.21.ebuild
deleted file mode 100644
index a49b3d6f0a4e..000000000000
--- a/sys-apps/sandbox/sandbox-2.21.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic multilib-minimal multiprocessing
-
-DESCRIPTION="sandbox'd LD_PRELOAD hack"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Sandbox"
-SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE=""
-
-DEPEND="app-arch/xz-utils
- >=app-misc/pax-utils-0.1.19" #265376
-RDEPEND=""
-
-has sandbox_death_notice ${EBUILD_DEATH_HOOKS} || EBUILD_DEATH_HOOKS="${EBUILD_DEATH_HOOKS} sandbox_death_notice"
-
-sandbox_death_notice() {
- ewarn "If configure failed with a 'cannot run C compiled programs' error, try this:"
- ewarn "FEATURES='-sandbox -usersandbox' emerge sandbox"
-}
-
-multilib_src_configure() {
- filter-lfs-flags #90228
-
- ECONF_SOURCE="${S}" econf
-}
-
-multilib_src_test() {
- # Default sandbox build will run with --jobs set to # cpus.
- emake -j1 check TESTSUITEFLAGS="--jobs=$(makeopts_jobs)"
-}
-
-multilib_src_install_all() {
- doenvd "${FILESDIR}"/09sandbox
-
- keepdir /var/log/sandbox
- fowners root:portage /var/log/sandbox
- fperms 0770 /var/log/sandbox
-
- dodoc AUTHORS ChangeLog* NEWS README
-}
-
-pkg_preinst() {
- chown root:portage "${ED}"/var/log/sandbox
- chmod 0770 "${ED}"/var/log/sandbox
-
- local v
- for v in ${REPLACING_VERSIONS}; do
- # 1.x was removed from ::gentoo in 2016
- if [[ ${v} == 1.* ]] ; then
- local old=$(find "${EROOT}"/lib* -maxdepth 1 -name 'libsandbox*')
- if [[ -n ${old} ]] ; then
- elog "Removing old sandbox libraries for you:"
- find "${EROOT}"/lib* -maxdepth 1 -name 'libsandbox*' -print -delete
- fi
- fi
- done
-}
-
-pkg_postinst() {
- local v
- for v in ${REPLACING_VERSIONS}; do
- # 1.x was removed from ::gentoo in 2016
- if [[ ${v} == 1.* ]] ; then
- chmod 0755 "${EROOT}"/etc/sandbox.d #265376
- fi
- done
-}
diff --git a/sys-apps/sandbox/sandbox-2.22.ebuild b/sys-apps/sandbox/sandbox-2.22.ebuild
deleted file mode 100644
index d8ef19b9ff30..000000000000
--- a/sys-apps/sandbox/sandbox-2.22.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic multilib-minimal multiprocessing
-
-DESCRIPTION="sandbox'd LD_PRELOAD hack"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Sandbox"
-SRC_URI="https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE=""
-
-DEPEND="app-arch/xz-utils
- >=app-misc/pax-utils-0.1.19" #265376
-RDEPEND=""
-
-has sandbox_death_notice ${EBUILD_DEATH_HOOKS} || EBUILD_DEATH_HOOKS="${EBUILD_DEATH_HOOKS} sandbox_death_notice"
-
-sandbox_death_notice() {
- ewarn "If configure failed with a 'cannot run C compiled programs' error, try this:"
- ewarn "FEATURES='-sandbox -usersandbox' emerge sandbox"
-}
-
-multilib_src_configure() {
- filter-lfs-flags #90228
-
- ECONF_SOURCE="${S}" econf
-}
-
-multilib_src_test() {
- # Default sandbox build will run with --jobs set to # cpus.
- # -j1 to prevent test faiures caused by file descriptor
- # injection GNU make does.
- emake -j1 check TESTSUITEFLAGS="--jobs=$(makeopts_jobs)"
-}
-
-multilib_src_install_all() {
- doenvd "${FILESDIR}"/09sandbox
-
- keepdir /var/log/sandbox
- fowners root:portage /var/log/sandbox
- fperms 0770 /var/log/sandbox
-
- dodoc AUTHORS ChangeLog* NEWS README
-}
-
-pkg_postinst() {
- chown root:portage "${EROOT}"/var/log/sandbox
- chmod 0770 "${EROOT}"/var/log/sandbox
-}
diff --git a/sys-apps/sandbox/sandbox-2.23.ebuild b/sys-apps/sandbox/sandbox-2.23.ebuild
deleted file mode 100644
index d8ef19b9ff30..000000000000
--- a/sys-apps/sandbox/sandbox-2.23.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic multilib-minimal multiprocessing
-
-DESCRIPTION="sandbox'd LD_PRELOAD hack"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Sandbox"
-SRC_URI="https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE=""
-
-DEPEND="app-arch/xz-utils
- >=app-misc/pax-utils-0.1.19" #265376
-RDEPEND=""
-
-has sandbox_death_notice ${EBUILD_DEATH_HOOKS} || EBUILD_DEATH_HOOKS="${EBUILD_DEATH_HOOKS} sandbox_death_notice"
-
-sandbox_death_notice() {
- ewarn "If configure failed with a 'cannot run C compiled programs' error, try this:"
- ewarn "FEATURES='-sandbox -usersandbox' emerge sandbox"
-}
-
-multilib_src_configure() {
- filter-lfs-flags #90228
-
- ECONF_SOURCE="${S}" econf
-}
-
-multilib_src_test() {
- # Default sandbox build will run with --jobs set to # cpus.
- # -j1 to prevent test faiures caused by file descriptor
- # injection GNU make does.
- emake -j1 check TESTSUITEFLAGS="--jobs=$(makeopts_jobs)"
-}
-
-multilib_src_install_all() {
- doenvd "${FILESDIR}"/09sandbox
-
- keepdir /var/log/sandbox
- fowners root:portage /var/log/sandbox
- fperms 0770 /var/log/sandbox
-
- dodoc AUTHORS ChangeLog* NEWS README
-}
-
-pkg_postinst() {
- chown root:portage "${EROOT}"/var/log/sandbox
- chmod 0770 "${EROOT}"/var/log/sandbox
-}