summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2022-06-03 09:30:23 -0400
committerKenton Groombridge <concord@gentoo.org>2022-06-03 21:03:07 -0400
commit7cf1fdecb5aaaf5eee9ca8c86c13c755985f63e6 (patch)
tree76ea4de05dfcde96dfe2771314045f96dda4e27b /sys-apps/secilc/secilc-3.4.ebuild
parentsys-libs/libsepol: bump to 3.4 (diff)
downloadgentoo-7cf1fdecb5aaaf5eee9ca8c86c13c755985f63e6.tar.gz
gentoo-7cf1fdecb5aaaf5eee9ca8c86c13c755985f63e6.tar.bz2
gentoo-7cf1fdecb5aaaf5eee9ca8c86c13c755985f63e6.zip
sys-apps/secilc: bump to 3.4
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'sys-apps/secilc/secilc-3.4.ebuild')
-rw-r--r--sys-apps/secilc/secilc-3.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/secilc/secilc-3.4.ebuild b/sys-apps/secilc/secilc-3.4.ebuild
new file mode 100644
index 000000000000..13b261011af0
--- /dev/null
+++ b/sys-apps/secilc/secilc-3.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+inherit toolchain-funcs
+
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="SELinux Common Intermediate Language (CIL) Compiler"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${PV}"
+RDEPEND="${DEPEND}"
+BDEPEND="app-text/xmlto"
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_compile() {
+ tc-export CC
+ default
+}