summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2020-12-21 18:51:44 -0500
committerJason Zaman <perfinion@gentoo.org>2021-01-03 00:19:50 -0800
commite2d9594242893b6c936e7d315ed5adb0f6acf02c (patch)
treeac01e9169ca7caa64cc01bcba3e584a12420bb86 /sys-apps/selinux-python/selinux-python-9999.ebuild
parentsys-libs/libsemanage: add python3_9 (diff)
downloadgentoo-e2d9594242893b6c936e7d315ed5adb0f6acf02c.tar.gz
gentoo-e2d9594242893b6c936e7d315ed5adb0f6acf02c.tar.bz2
gentoo-e2d9594242893b6c936e7d315ed5adb0f6acf02c.zip
sys-apps/selinux-python: drop obsolete ipy dep
https://github.com/SELinuxProject/selinux/commit/79f69a3ca1bfa0ebafcdae976858c60bae170e1b Also add python3_9 to the live ebuild. Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps/selinux-python/selinux-python-9999.ebuild')
-rw-r--r--sys-apps/selinux-python/selinux-python-9999.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/sys-apps/selinux-python/selinux-python-9999.ebuild b/sys-apps/selinux-python/selinux-python-9999.ebuild
index e3fe4738a86b..b244747ca977 100644
--- a/sys-apps/selinux-python/selinux-python-9999.ebuild
+++ b/sys-apps/selinux-python/selinux-python-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
PYTHON_REQ_USE="xml"
inherit python-r1 toolchain-funcs
@@ -14,7 +14,6 @@ SEPOL_VER="${PV}"
SELNX_VER="${PV}"
SEMNG_VER="${PV}"
-IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DESCRIPTION="SELinux core utilities"
@@ -37,7 +36,6 @@ DEPEND=">=sys-libs/libselinux-${SELNX_VER}:=[python]
>=sys-libs/libsemanage-${SEMNG_VER}:=[python(+)]
>=sys-libs/libsepol-${SEPOL_VER}:=
>=app-admin/setools-4.2.0[${PYTHON_USEDEP}]
- dev-python/ipy[${PYTHON_USEDEP}]
>=sys-process/audit-1.5.1[python,${PYTHON_USEDEP}]
${PYTHON_DEPS}"