summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2022-11-13 20:45:53 +0000
committerSam James <sam@gentoo.org>2022-11-18 02:18:16 +0000
commita1e9afb52621981f5e77546348f99d244ddcdb22 (patch)
tree1088dd729ecb15e563f1044ae42459b931cf8583 /sys-apps/sg3_utils/sg3_utils-1.47-r1.ebuild
parentsys-fs/jfsutils: musl patch (diff)
downloadgentoo-a1e9afb52621981f5e77546348f99d244ddcdb22.tar.gz
gentoo-a1e9afb52621981f5e77546348f99d244ddcdb22.tar.bz2
gentoo-a1e9afb52621981f5e77546348f99d244ddcdb22.zip
sys-apps/sg3_utils: musl uint fix
Upstream patch for cherry pick - https://github.com/doug-gilbert/sg3_utils/commit/9e6d513fe192e53778b6dd98954e43b8e6f0c3a6.patch This patch allows sg3_utils to work under Musl by replacing uint with uint32_t and has been tested on amd64 and PPC. Upstream bug: https://github.com/doug-gilbert/sg3_utils/pull/7 Closes: https://bugs.gentoo.org/828897 Thanks-to: ayuayuayu Signed-off-by: Ian Jordan <immoloism@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/28259 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/sg3_utils/sg3_utils-1.47-r1.ebuild')
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.47-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/sg3_utils/sg3_utils-1.47-r1.ebuild b/sys-apps/sg3_utils/sg3_utils-1.47-r1.ebuild
new file mode 100644
index 000000000000..b88d096ba1a7
--- /dev/null
+++ b/sys-apps/sg3_utils/sg3_utils-1.47-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Apps for querying the sg SCSI interface"
+HOMEPAGE="https://sg.danny.cz/sg/"
+#SRC_URI="https://github.com/hreinecke/sg3_utils/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://sg.danny.cz/sg/p/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="sys-devel/libtool"
+RDEPEND="!sys-apps/rescan-scsi-bus"
+
+PATCHES=(
+ # Bug #828897
+ "${FILESDIR}"/${PN}-1.47-musl.patch
+)
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ dodoc COVERAGE doc/README examples/*.txt
+ newdoc scripts/README README.scripts
+
+ find "${ED}" -type f -name "*.la" -delete || die
+
+ # Better fix for bug 231089; some packages look for sgutils2
+ local path lib
+ path="/usr/$(get_libdir)"
+ for lib in "${ED}/"${path}/libsgutils2{,-${PV}}.*; do
+ lib=${lib##*/}
+ dosym "${lib}" "${path}/${lib/libsgutils2/libsgutils}"
+ done
+}