summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2024-08-11 17:02:45 -0700
committerJason Zaman <perfinion@gentoo.org>2024-08-11 18:20:43 -0700
commit0011c69be710c02fa4c03e213aa8a6d849b94903 (patch)
tree5606940dbcd179166a597e7981bc45f126c47e85 /sys-apps
parentsys-apps/policycoreutils: drop 3.5 (diff)
downloadgentoo-0011c69be710c02fa4c03e213aa8a6d849b94903.tar.gz
gentoo-0011c69be710c02fa4c03e213aa8a6d849b94903.tar.bz2
gentoo-0011c69be710c02fa4c03e213aa8a6d849b94903.zip
sys-apps/selinux-python: drop 3.5
Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/selinux-python/Manifest1
-rw-r--r--sys-apps/selinux-python/selinux-python-3.5.ebuild114
2 files changed, 0 insertions, 115 deletions
diff --git a/sys-apps/selinux-python/Manifest b/sys-apps/selinux-python/Manifest
index 2891961c7ef0..00d542eb5373 100644
--- a/sys-apps/selinux-python/Manifest
+++ b/sys-apps/selinux-python/Manifest
@@ -1,3 +1,2 @@
-DIST selinux-python-3.5.tar.gz 3604439 BLAKE2B 5a7fcd303c337cb0f5ae0066d13c945bb5cacaba472c7b17f0496295294998fcc6d81c153720ef704b749a01590c28b48b4f471a48fc386b8f02564c3550250b SHA512 2ac176a9f078f2b2721e5871ba21e92041eed54fc692fd8d809ff14327beee6de63b3084d0f1053a640b9e40bcc6461498915bb9b038a658cd772f77d80fd217
DIST selinux-python-3.6.tar.gz 3633272 BLAKE2B c2b99779eda2c7698f7f68740e3136cbfa5ab471a5d154142aafd2694d8c32aa605df3609a3667c687449d3ba44e72bcc3b37c36adecba8e34fcc629b9f04de5 SHA512 6289f3f2a3038b2cb62f6b3b12c729a9981c34a5ee80c0830e6316e8c77f5283dffa46007f6e7dc073332b829ed9953ba54e64c986fb18c7dc40759ec0375dc9
DIST selinux-python-3.7.tar.gz 3652377 BLAKE2B 59fd7cab0034c175f42f6120ba665701945adcbd4e8af97a0dc2a1c79688a596b199528886ceea079a3f7a969258611fb660449d313d9e893de381293e786381 SHA512 036bc1f0e64cbbaade592dc7899a92765a0bac426140d7d3960f73bad6eb5f95d79d91e0f0e1604f88a991ebf59c4c90ccaaa4158f5dc4d3275ca2aed1673b09
diff --git a/sys-apps/selinux-python/selinux-python-3.5.ebuild b/sys-apps/selinux-python/selinux-python-3.5.ebuild
deleted file mode 100644
index 9fa9dc5ecf0f..000000000000
--- a/sys-apps/selinux-python/selinux-python-3.5.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit python-r1 toolchain-funcs
-
-MY_PV="${PV//_/-}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="SELinux core utilities"
-HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
- S="${WORKDIR}/${P}/${PN#selinux-}"
-else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
- KEYWORDS="amd64 arm arm64 ~mips x86"
- S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND=">=sys-libs/libselinux-${PV}:=[python]
- >=sys-libs/libsemanage-${PV}:=[python(+)]
- >=sys-libs/libsepol-${PV}:=[static-libs(+)]
- >=app-admin/setools-4.2.0[${PYTHON_USEDEP}]
- >=sys-process/audit-1.5.1[python,${PYTHON_USEDEP}]
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}"
-BDEPEND="
- test? (
- ${RDEPEND}
- >=sys-apps/secilc-${PV}
- )"
-
-src_prepare() {
- default
- sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
-
- python_copy_sources
-}
-
-src_compile() {
- building() {
- emake -C "${BUILD_DIR}" \
- CC="$(tc-getCC)" \
- LIBDIR="\$(PREFIX)/$(get_libdir)"
- }
- python_foreach_impl building
-}
-
-src_test() {
- testing() {
- # The different subprojects have some interproject dependencies:
- # - audit2allow depens on sepolgen
- # - chcat depends on semanage
- # and maybe others.
- # Add all the modules of the individual subprojects to the
- # PYTHONPATH, so they get actually found and used. In
- # particular, already installed versions on the system are not
- # used.
- for dir in audit2allow chcat semanage sepolgen/src sepolicy ; do
- PYTHONPATH="${BUILD_DIR}/${dir}:${PYTHONPATH}"
- done
- PYTHONPATH=${PYTHONPATH} \
- emake -C "${BUILD_DIR}" \
- test
- }
- python_foreach_impl testing
-}
-
-src_install() {
- installation() {
- emake -C "${BUILD_DIR}" \
- DESTDIR="${D}" \
- LIBDIR="\$(PREFIX)/$(get_libdir)" \
- install
- python_optimize
- }
- python_foreach_impl installation
-
- # Set version-specific scripts
- for pyscript in audit2allow sepolgen-ifgen sepolicy chcat; do
- python_replicate_script "${ED}/usr/bin/${pyscript}"
- done
- for pyscript in semanage; do
- python_replicate_script "${ED}/usr/sbin/${pyscript}"
- done
-
- # Create sepolgen.conf with different devel location definition
- mkdir -p "${D}"/etc/selinux || die "Failed to create selinux directory";
- if [[ -f /etc/selinux/config ]];
- then
- local selinuxtype=$(awk -F'=' '/^SELINUXTYPE/ {print $2}' /etc/selinux/config);
- echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
- else
- local selinuxtype="${POLICY_TYPES%% *}";
- if [[ -n "${selinuxtype}" ]];
- then
- echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
- else
- echo "SELINUX_DEVEL_PATH=/usr/share/selinux/strict/include:/usr/share/selinux/strict" > "${D}"/etc/selinux/sepolgen.conf;
- fi
- fi
-}