summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2022-06-03 06:11:36 +0100
committerSam James <sam@gentoo.org>2022-06-03 06:29:07 +0100
commit62aa412c33b4364105b14c904e32738617e8ea88 (patch)
tree5a77561ff0656139f790ecad3ac4f8c2eb06cd74 /sys-apps
parentmedia-gfx/graphviz: use confcache (diff)
downloadgentoo-62aa412c33b4364105b14c904e32738617e8ea88.tar.gz
gentoo-62aa412c33b4364105b14c904e32738617e8ea88.tar.bz2
gentoo-62aa412c33b4364105b14c904e32738617e8ea88.zip
sys-apps/daisydog: improve OpenRC init script
The attached script updates a couple things which effectively is the same as the current model however it follows the modular nature of the declarative syntax. Changes: * Split start_stop_daemon_args into command_background and pidfile options. Closes: https://bugs.gentoo.org/828084 Signed-off-by: Brian Evans <grknight@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/daisydog/daisydog-2014.05.30-r1.ebuild33
-rw-r--r--sys-apps/daisydog/files/daisydog.init.d-r113
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-apps/daisydog/daisydog-2014.05.30-r1.ebuild b/sys-apps/daisydog/daisydog-2014.05.30-r1.ebuild
new file mode 100644
index 000000000000..880303643aee
--- /dev/null
+++ b/sys-apps/daisydog/daisydog-2014.05.30-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs flag-o-matic
+
+GIT_SHA1="3182aa85c087446e4358370549adc45db21ec124"
+MY_P="${PN}-${GIT_SHA1}"
+
+DESCRIPTION="A very simple /dev/watchdog daemon"
+HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/daisydog/+/master"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz
+ https://chromium.googlesource.com/chromiumos/third_party/daisydog/+archive/${GIT_SHA1}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="static"
+
+src_configure() {
+ tc-export CC
+ use static && append-ldflags -static
+}
+
+src_install() {
+ dobin daisydog
+ dodoc README.chromiumos
+
+ newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
+ newinitd "${FILESDIR}"/${PN}.init.d-r1 ${PN}
+}
diff --git a/sys-apps/daisydog/files/daisydog.init.d-r1 b/sys-apps/daisydog/files/daisydog.init.d-r1
new file mode 100644
index 000000000000..9d9efdd42772
--- /dev/null
+++ b/sys-apps/daisydog/files/daisydog.init.d-r1
@@ -0,0 +1,13 @@
+#!/sbin/openrc-run
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+command="/usr/bin/daisydog"
+command_args="${WATCHDOG_OPTS}"
+description="watchdog daemon to pet /dev/watchdog devices"
+command_background="yes"
+pidfile="/run/daisydog.pid"
+
+depend() {
+ provide watchdog
+}