summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2024-06-06 10:00:00 -0400
committerMike Gilbert <floppym@gentoo.org>2024-06-06 10:01:41 -0400
commit6de415c71946be5f07484e8974297643b93da5b6 (patch)
tree61ecf642ab8332c324095c9f9152217b51491684 /sys-apps
parentsys-apps/policycoreutils: enable py3.12 (diff)
downloadgentoo-6de415c71946be5f07484e8974297643b93da5b6.tar.gz
gentoo-6de415c71946be5f07484e8974297643b93da5b6.tar.bz2
gentoo-6de415c71946be5f07484e8974297643b93da5b6.zip
sys-apps/systemd-utils: create /lib/{systemd,udev} symlinks in preinst
This should avoid any file collsion checking. Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd-utils/systemd-utils-255.7.ebuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/sys-apps/systemd-utils/systemd-utils-255.7.ebuild b/sys-apps/systemd-utils/systemd-utils-255.7.ebuild
index 767e5a8b7ec6..f34f50b1db52 100644
--- a/sys-apps/systemd-utils/systemd-utils-255.7.ebuild
+++ b/sys-apps/systemd-utils/systemd-utils-255.7.ebuild
@@ -558,11 +558,6 @@ multilib_src_install_all() {
use ukify && python_fix_shebang "${ED}"
use boot && secureboot_auto_sign
-
- if use split-usr; then
- dosym ../usr/lib/systemd /lib/systemd
- dosym ../usr/lib/udev /lib/udev
- fi
}
add_service() {
@@ -577,8 +572,9 @@ add_service() {
pkg_preinst() {
# Migrate /lib/{systemd,udev} to /usr/lib
- # Symlinks will be installed in the merge phase
if use split-usr; then
+ dosym ../usr/lib/systemd /lib/systemd
+ dosym ../usr/lib/udev /lib/udev
local d
for d in systemd udev; do
if [[ -e ${EROOT}/lib/${d} && ! -L ${EROOT}/lib/${d} ]]; then