summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-15 01:17:54 +0100
committerSam James <sam@gentoo.org>2024-08-15 01:26:15 +0100
commit8cd290459d50be32b0a3428b999496acb537a669 (patch)
tree089f983c2051bb91bae865685bedd9008ea3f8f8 /sys-apps
parentdev-util/diffoscope: add 274 (diff)
downloadgentoo-8cd290459d50be32b0a3428b999496acb537a669.tar.gz
gentoo-8cd290459d50be32b0a3428b999496acb537a669.tar.bz2
gentoo-8cd290459d50be32b0a3428b999496acb537a669.zip
sys-apps/moar: add 1.26.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/moar/Manifest2
-rw-r--r--sys-apps/moar/moar-1.26.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
index dd67e2ce595b..5e8488f91f3e 100644
--- a/sys-apps/moar/Manifest
+++ b/sys-apps/moar/Manifest
@@ -8,3 +8,5 @@ DIST moar-1.24.4-deps.tar.xz 1228028 BLAKE2B f8895cef15f6ab0eb5dcf826d86deb7dc2c
DIST moar-1.24.4.tar.gz 2806042 BLAKE2B bbe10b9c829074a572f7b741eb5349d02329decc2bdec85e743e177784530ae349653a6941b994c2a3de6496d5ce39c451480a689ceae9daeba6ab13c9e6f555 SHA512 872e7a537b6383665b8f2af0ba92973dca3fa7c1c240db1be34b97cb38274e7aeb81281371809972004f08424bdd78d6c32bc39db2a4ecf22545c5c5ab38ee7b
DIST moar-1.24.6-deps.tar.xz 1228028 BLAKE2B f8895cef15f6ab0eb5dcf826d86deb7dc2c67dd6e692e456d5d98830fba93b3a17e5d3b3026c0f7ea10e3810db1f17ccb27b3cb704cff1c9bcbd267fbf68acbd SHA512 f12f2fa563b5170c8fe092f15476692815c2e0ab341d8becff504e5ded426efae5fc20697ef935ca5d037fa40abbfebbe5d0f59ac4e805e2d7d60e19070df3d4
DIST moar-1.24.6.tar.gz 2806800 BLAKE2B c412c62f7a1c9dba73e1ae7b31d43ffa58789e93a22b357dc4469168fd5cef95732a2363fadb4b4266169de5aaf3e541c4212730425e4c2ad91f194c7e9107f7 SHA512 77d5b789449806e8355702af762cd4cd604a885e7ffdebfcd6601073ea8cd0893c12999662352780d9915a9fbcb3bbc35e1e5b637e1ae15f73a5e65ca632193e
+DIST moar-1.26.0-deps.tar.xz 1228028 BLAKE2B f8895cef15f6ab0eb5dcf826d86deb7dc2c67dd6e692e456d5d98830fba93b3a17e5d3b3026c0f7ea10e3810db1f17ccb27b3cb704cff1c9bcbd267fbf68acbd SHA512 f12f2fa563b5170c8fe092f15476692815c2e0ab341d8becff504e5ded426efae5fc20697ef935ca5d037fa40abbfebbe5d0f59ac4e805e2d7d60e19070df3d4
+DIST moar-1.26.0.tar.gz 2811931 BLAKE2B 8f0ed34aeb5a4116a8a42cbef2f40f0ed81a60f5bb9160ec743694263e35674f126b0ec359e0ec390baed7f8cf6c4d457cf4e401c4ef951cc7dd9163b0a0e2f7 SHA512 e3de7183df6b4e29ffa43f1681b8c5bc207a7f4e33ad42c3021a4260da91bb8ade3bb4f3c7d9cd6603cb416c7f4c976d2525d96862deff3080c9d1ec17c127ef
diff --git a/sys-apps/moar/moar-1.26.0.ebuild b/sys-apps/moar/moar-1.26.0.ebuild
new file mode 100644
index 000000000000..928e03d26244
--- /dev/null
+++ b/sys-apps/moar/moar-1.26.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-env go-module
+
+DESCRIPTION="Pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI="https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# moarvm: https://github.com/walles/moar/issues/143
+RDEPEND="!dev-lang/moarvm"
+BDEPEND="
+ test? (
+ app-arch/bzip2
+ app-arch/xz-utils
+ )
+"
+
+src_unpack() {
+ default
+
+ if [[ -d "${WORKDIR}"/vendor ]] ; then
+ mv "${WORKDIR}"/vendor "${S}"/vendor || die
+ fi
+ go-env_set_compile_environment
+}
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}