summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2025-01-06 15:23:55 +0000
committerJames Le Cuirot <chewi@gentoo.org>2025-01-06 15:23:55 +0000
commit8ce2609bbfa00a08eba6c617a3681b6e2b61d0e3 (patch)
tree4bf7d2caf2c81cbd557aafd949735beefc09295e /sys-apps
parentnet-wireless/unifi: drop 8.5.6 (diff)
downloadgentoo-8ce2609bbfa00a08eba6c617a3681b6e2b61d0e3.tar.gz
gentoo-8ce2609bbfa00a08eba6c617a3681b6e2b61d0e3.tar.bz2
gentoo-8ce2609bbfa00a08eba6c617a3681b6e2b61d0e3.zip
sys-apps/intune-portal: Version bump to 1.2411.14
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/intune-portal/Manifest1
-rw-r--r--sys-apps/intune-portal/intune-portal-1.2411.14.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/sys-apps/intune-portal/Manifest b/sys-apps/intune-portal/Manifest
index 87af5741bd88..892fb6d4cb87 100644
--- a/sys-apps/intune-portal/Manifest
+++ b/sys-apps/intune-portal/Manifest
@@ -1 +1,2 @@
DIST intune-portal_1.2405.17-jammy_amd64.deb 6662402 BLAKE2B 0f745cb0ebe6876645b14db04ba50e840cb11cfa8e9239080704299e461ffaded22f9e854ff8c635c08289e4b15f128780f30a6e2ef03d2ded4f2f1db512d3cc SHA512 5188f7467ed7cd85c8a70a24669ad2906517e71a5ca2f06f27437e9078df569afbf95c3b7b02b2c65dc85c2e58a799313e30211bab9226fabe4399a2bdb52073
+DIST intune-portal_1.2411.14-noble_amd64.deb 6606406 BLAKE2B 3c56cb0f5c264cda4a008dd49860c721c0ab94d25f9af065c7e523e656884ff42a600be2f93f8a5247090e34e63fdf15804bc14b17e2c1e0318db2b23e618db7 SHA512 09c3e00739edbff611334f4faf3e0337e33db9e51d203d12169ef696f8dcf3d96bab0fa57e51edb5800656413e74986d814d30494d20c25b7b709a586364919a
diff --git a/sys-apps/intune-portal/intune-portal-1.2411.14.ebuild b/sys-apps/intune-portal/intune-portal-1.2411.14.ebuild
new file mode 100644
index 000000000000..2eb398023df2
--- /dev/null
+++ b/sys-apps/intune-portal/intune-portal-1.2411.14.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pam prefix systemd tmpfiles unpacker xdg
+
+DESCRIPTION="Microsoft Intune Company Portal to access a corporate environment"
+HOMEPAGE="https://learn.microsoft.com/mem/intune/"
+SRC_URI="https://packages.microsoft.com/ubuntu/24.04/prod/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-noble_amd64.deb"
+S="${WORKDIR}"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ app-accessibility/at-spi2-core:2
+ app-crypt/libsecret
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/openssl:0/3
+ net-libs/libsoup:3.0
+ net-libs/webkit-gtk:4.1/0
+ net-misc/curl
+ sys-apps/bubblewrap
+ sys-apps/dbus
+ sys-apps/lsb-release
+ sys-apps/systemd
+ sys-apps/util-linux
+ sys-auth/microsoft-identity-broker
+ sys-auth/pambase[pwquality]
+ sys-auth/polkit
+ sys-libs/pam
+ sys-libs/zlib
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/pango
+
+ || (
+ www-client/microsoft-edge
+ www-client/microsoft-edge-beta
+ www-client/microsoft-edge-dev
+ )
+"
+
+QA_PREBUILT="*"
+DIR="/opt/microsoft/intune"
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_install() {
+ exeinto "${DIR}"/bin
+ newexe $(prefixify_ro "${FILESDIR}"/wrapper) intune-portal
+ dosym intune-portal /opt/microsoft/intune/bin/intune-agent
+ dosym intune-portal /opt/microsoft/intune/bin/intune-daemon
+
+ exeinto "${DIR}"/libexec
+ doexe "${DIR#/}"/bin/*
+
+ insinto "${DIR}"/share
+ doins -r "${DIR#/}"/share/*
+
+ insinto /usr/share/polkit-1/actions
+ doins usr/share/polkit-1/actions/com.microsoft.intune.policy
+
+ systemd_dounit lib/systemd/system/*
+ systemd_douserunit lib/systemd/user/*
+
+ dopammod usr/lib/x86_64-linux-gnu/security/pam_intune.so
+ dotmpfiles usr/lib/tmpfiles.d/intune.conf
+
+ domenu usr/share/applications/*.desktop
+ doicon -s 48 usr/share/icons/hicolor/48x48/*/*.png
+}
+
+pkg_postinst() {
+ touch "${EROOT}"/etc/pam.d/common-password || die
+ tmpfiles_process intune.conf
+ xdg_pkg_postinst
+}