summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-05-06 21:31:17 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-05-06 21:31:22 +0200
commitd97b5d8b14bec5d8bd9619b000f06aa45d2baade (patch)
tree237dcf7f0abe32f8e781b00c0b6dbbb8bdb2295a /sys-apps
parentmedia-libs/libmypaint: enable py3.12 (diff)
downloadgentoo-d97b5d8b14bec5d8bd9619b000f06aa45d2baade.tar.gz
gentoo-d97b5d8b14bec5d8bd9619b000f06aa45d2baade.tar.bz2
gentoo-d97b5d8b14bec5d8bd9619b000f06aa45d2baade.zip
sys-apps/biosdevname: update EAPI 7 -> 8, call udev_reload, fix deps
pciutils is an rdep: !!! existing preserved libs: >>> package: sys-apps/pciutils-3.10.0 * - /usr/lib64/libpci.so.3 * - /usr/lib64/libpci.so.3.10.0 * used by /usr/sbin/biosdevname (sys-apps/biosdevname-0.7.3) Use emerge @preserved-rebuild to rebuild packages using these libraries Closes: https://bugs.gentoo.org/851804 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/biosdevname/biosdevname-0.7.3-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/biosdevname/biosdevname-0.7.3-r1.ebuild b/sys-apps/biosdevname/biosdevname-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..9a09515f1a4f
--- /dev/null
+++ b/sys-apps/biosdevname/biosdevname-0.7.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools udev
+
+DESCRIPTION="Sets BIOS-given device names instead of kernel eth* names"
+HOMEPAGE="
+ https://linux.dell.com/biosdevname/
+ https://github.com/dell/biosdevname
+"
+SRC_URI="https://github.com/dell/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ virtual/udev
+ sys-apps/pciutils
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i -e 's|/sbin/biosdevname|/usr\0|g' biosdevname.rules.in || die
+ sed -i -e "/RULEDEST/s:/lib/udev:$(get_udevdir):" configure.ac || die
+
+ eautoreconf
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}