summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-28 01:31:31 +0000
committerSam James <sam@gentoo.org>2023-01-28 01:33:16 +0000
commitd7da98abe0bfa8bc168818b78b663489513ac43f (patch)
treefbbd00637364858188b5171a2731387f6e08a1e7 /sys-block/sedutil
parentdev-python/greenlet: add github upstream metadata (diff)
downloadgentoo-d7da98abe0bfa8bc168818b78b663489513ac43f.tar.gz
gentoo-d7da98abe0bfa8bc168818b78b663489513ac43f.tar.bz2
gentoo-d7da98abe0bfa8bc168818b78b663489513ac43f.zip
sys-block/sedutil: fix build w/ gcc 13
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-block/sedutil')
-rw-r--r--sys-block/sedutil/files/sedutil-1.20.0-gcc-13.patch25
-rw-r--r--sys-block/sedutil/sedutil-1.20.0.ebuild6
2 files changed, 30 insertions, 1 deletions
diff --git a/sys-block/sedutil/files/sedutil-1.20.0-gcc-13.patch b/sys-block/sedutil/files/sedutil-1.20.0-gcc-13.patch
new file mode 100644
index 000000000000..7b803028230b
--- /dev/null
+++ b/sys-block/sedutil/files/sedutil-1.20.0-gcc-13.patch
@@ -0,0 +1,25 @@
+https://github.com/Drive-Trust-Alliance/sedutil/pull/425
+
+From 927cd88cad7bea94c2eebecc18f7881f0defaccb Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 26 Jan 2023 23:36:29 -0800
+Subject: [PATCH] include missing <cstdint>
+
+gcc 13 moved some includes around and as a result <cstdint>
+is no longer transitively included [1]. Explicitly include
+it for uint{32,64}_t.
+
+[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/Common/DtaOptions.h
++++ b/Common/DtaOptions.h
+@@ -21,6 +21,7 @@ along with sedutil. If not, see <http://www.gnu.org/licenses/>.
+ #ifndef _DTAOPTIONS_H
+ #define _DTAOPTIONS_H
+
++#include <cstdint>
+ /** Output modes */
+ typedef enum _sedutiloutput {
+ sedutilNormal,
+
diff --git a/sys-block/sedutil/sedutil-1.20.0.ebuild b/sys-block/sedutil/sedutil-1.20.0.ebuild
index 917e43286854..d920ad8c3c36 100644
--- a/sys-block/sedutil/sedutil-1.20.0.ebuild
+++ b/sys-block/sedutil/sedutil-1.20.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,6 +13,10 @@ LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="amd64 ~ppc64 x86"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.20.0-gcc-13.patch
+)
+
src_prepare() {
default
# https://github.com/Drive-Trust-Alliance/sedutil/pull/49