summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-27 20:20:10 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-27 22:34:34 -0400
commit5f3a7d49a6ce95d321a89863a7fa8023ae798383 (patch)
tree3f69a3e7e5c02d05c37187e9190e814f986bf40f /sys-block
parentmedia-sound/aseqview: fix build with clang16 (diff)
downloadgentoo-5f3a7d49a6ce95d321a89863a7fa8023ae798383.tar.gz
gentoo-5f3a7d49a6ce95d321a89863a7fa8023ae798383.tar.bz2
gentoo-5f3a7d49a6ce95d321a89863a7fa8023ae798383.zip
sys-block/scsiping: EAPI7->8, respect CC, remove dead HOMEPAGE
Closes: https://bugs.gentoo.org/725768 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/scsiping/scsiping-0.0.1-r1.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/sys-block/scsiping/scsiping-0.0.1-r1.ebuild b/sys-block/scsiping/scsiping-0.0.1-r1.ebuild
index c3cc60f5cb01..745fd177ef62 100644
--- a/sys-block/scsiping/scsiping-0.0.1-r1.ebuild
+++ b/sys-block/scsiping/scsiping-0.0.1-r1.ebuild
@@ -1,23 +1,26 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit toolchain-funcs
DESCRIPTION="SCSIPing pings a host on the SCSI-chain"
-HOMEPAGE="https://www.vanheusden.com/Linux/"
-SRC_URI="https://www.vanheusden.com/Linux/${P}.tgz"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
src_prepare() {
- sed -i -e '/strip scsiping/d' "${S}"/Makefile
default
+
+ sed -i '/strip scsiping/d' Makefile || die
}
src_compile() {
- emake DEBUG='' CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
}
src_install() {