summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-08-02 23:37:57 +0800
committerJason Zaman <perfinion@gentoo.org>2017-08-02 23:37:57 +0800
commit7fac5fc88b4e188d8e6922fc723805ca9e75636d (patch)
tree2fe3d42b8b07be0925454d6ac6929939f062c86c /sys-boot
parentwww-servers/varnish: remove vulnerable unstable versions (diff)
downloadgentoo-7fac5fc88b4e188d8e6922fc723805ca9e75636d.tar.gz
gentoo-7fac5fc88b4e188d8e6922fc723805ca9e75636d.tar.bz2
gentoo-7fac5fc88b4e188d8e6922fc723805ca9e75636d.zip
sys-boot/tboot: fix grub scripts to find initrd
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/tboot/files/tboot-1.9.5-genkernel-path.patch18
-rw-r--r--sys-boot/tboot/tboot-1.9.5-r1.ebuild (renamed from sys-boot/tboot/tboot-1.9.5.ebuild)2
2 files changed, 11 insertions, 9 deletions
diff --git a/sys-boot/tboot/files/tboot-1.9.5-genkernel-path.patch b/sys-boot/tboot/files/tboot-1.9.5-genkernel-path.patch
index 63e67f119ced..4914be6e4e7d 100644
--- a/sys-boot/tboot/files/tboot-1.9.5-genkernel-path.patch
+++ b/sys-boot/tboot/files/tboot-1.9.5-genkernel-path.patch
@@ -1,10 +1,11 @@
diff -ur tboot-1.9.5.orig/tboot/20_linux_tboot tboot-1.9.5/tboot/20_linux_tboot
---- tboot-1.9.5.orig/tboot/20_linux_tboot 2016-12-30 17:37:08.625535208 +0800
-+++ tboot-1.9.5/tboot/20_linux_tboot 2016-12-30 17:42:38.405714435 +0800
-@@ -171,6 +171,14 @@
+--- tboot-1.9.5.orig/tboot/20_linux_tboot 2016-12-21 06:29:15.000000000 +0800
++++ tboot-1.9.5/tboot/20_linux_tboot 2017-08-02 23:33:52.732748172 +0800
+@@ -171,6 +171,15 @@
EOF
}
++machine=`uname -m`
+case "$machine" in
+ i?86) GENKERNEL_ARCH="x86" ;;
+ mips|mips64) GENKERNEL_ARCH="mips" ;;
@@ -16,7 +17,7 @@ diff -ur tboot-1.9.5.orig/tboot/20_linux_tboot tboot-1.9.5/tboot/20_linux_tboot
linux_list=`for i in /boot/vmlinu[xz]-* /vmlinu[xz]-* ; do
basename=$(basename $i)
version=$(echo $basename | sed -e "s,^[^0-9]*-,,g")
-@@ -217,7 +225,9 @@
+@@ -217,7 +226,9 @@
"initrd.img-${alt_version}" "initrd-${alt_version}.img" \
"initrd-${alt_version}" "initramfs-${alt_version}.img" \
"initramfs-genkernel-${version}" \
@@ -28,12 +29,13 @@ diff -ur tboot-1.9.5.orig/tboot/20_linux_tboot tboot-1.9.5/tboot/20_linux_tboot
initrd="$i"
break
diff -ur tboot-1.9.5.orig/tboot/20_linux_xen_tboot tboot-1.9.5/tboot/20_linux_xen_tboot
---- tboot-1.9.5.orig/tboot/20_linux_xen_tboot 2016-12-30 17:37:08.628535191 +0800
-+++ tboot-1.9.5/tboot/20_linux_xen_tboot 2016-12-30 17:43:39.112379262 +0800
-@@ -165,6 +165,14 @@
+--- tboot-1.9.5.orig/tboot/20_linux_xen_tboot 2016-12-21 06:29:54.000000000 +0800
++++ tboot-1.9.5/tboot/20_linux_xen_tboot 2017-08-02 23:34:01.347685520 +0800
+@@ -165,6 +165,15 @@
EOF
}
++machine=`uname -m`
+case "$machine" in
+ i?86) GENKERNEL_ARCH="x86" ;;
+ mips|mips64) GENKERNEL_ARCH="mips" ;;
@@ -45,7 +47,7 @@ diff -ur tboot-1.9.5.orig/tboot/20_linux_xen_tboot tboot-1.9.5/tboot/20_linux_xe
linux_list=`for i in /boot/vmlinu[xz]-* /vmlinu[xz]-* /boot/kernel-*; do
if grub_file_is_not_garbage "$i"; then
basename=$(basename $i)
-@@ -232,7 +240,9 @@
+@@ -232,7 +241,9 @@
"initrd-${version}" "initrd.img-${alt_version}" \
"initrd-${alt_version}.img" "initrd-${alt_version}" \
"initramfs-genkernel-${version}" \
diff --git a/sys-boot/tboot/tboot-1.9.5.ebuild b/sys-boot/tboot/tboot-1.9.5-r1.ebuild
index fc626a1cd833..9e6d141c268e 100644
--- a/sys-boot/tboot/tboot-1.9.5.ebuild
+++ b/sys-boot/tboot/tboot-1.9.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6