summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBiosias <jakub@gdos.sk>2024-04-04 11:10:37 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-04-09 11:45:44 +0200
commitc69a7f740499b497770c90b38e7753f4a5ab71e7 (patch)
tree5131ecabb94055e2221e250f54a38934de03c24d /sys-boot
parentsci-electronics/nvc: bump to 1.12.0 (diff)
downloadgentoo-c69a7f740499b497770c90b38e7753f4a5ab71e7.tar.gz
gentoo-c69a7f740499b497770c90b38e7753f4a5ab71e7.tar.bz2
gentoo-c69a7f740499b497770c90b38e7753f4a5ab71e7.zip
sys-boot/uefi-mkconfig: new package, add 1.4
Signed-off-by: Biosias <jakub@gdos.sk> Closes: https://github.com/gentoo/gentoo/pull/36171 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/uefi-mkconfig/Manifest1
-rw-r--r--sys-boot/uefi-mkconfig/metadata.xml16
-rw-r--r--sys-boot/uefi-mkconfig/uefi-mkconfig-1.4.ebuild35
3 files changed, 52 insertions, 0 deletions
diff --git a/sys-boot/uefi-mkconfig/Manifest b/sys-boot/uefi-mkconfig/Manifest
new file mode 100644
index 000000000000..dfaeef8f744c
--- /dev/null
+++ b/sys-boot/uefi-mkconfig/Manifest
@@ -0,0 +1 @@
+DIST uefi-mkconfig-1.4.tar.gz 7844 BLAKE2B 4266c8c934f665c85d54699ebdd11648692b1eff2e0d4111de8329e01dee3342c760d772da27a8862e0427fcbecb38a9c0499ee482aa1ee0dcf72d0f30be97ef SHA512 47e096571899c18decd24c65df9bdd9da964e1e47120504d8c9761b7c2b80172b17a9259f229c267c95d7ee4ac24a1e79a3d0f13d15fc2effee7fcee8b1ce3ea
diff --git a/sys-boot/uefi-mkconfig/metadata.xml b/sys-boot/uefi-mkconfig/metadata.xml
new file mode 100644
index 000000000000..449694d29242
--- /dev/null
+++ b/sys-boot/uefi-mkconfig/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>jakub@gdos.sk</email>
+ <name>Jakub Gajdoš</name>
+ </maintainer>
+ <maintainer type="person" proxied="proxy">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Biosias/uefi-mkconfig</remote-id>
+ <bugs-to>https://github.com/Biosias/uefi-mkconfig/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-boot/uefi-mkconfig/uefi-mkconfig-1.4.ebuild b/sys-boot/uefi-mkconfig/uefi-mkconfig-1.4.ebuild
new file mode 100644
index 000000000000..0729f2e0a75f
--- /dev/null
+++ b/sys-boot/uefi-mkconfig/uefi-mkconfig-1.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info optfeature
+
+DESCRIPTION="Automatic management of UEFI entries"
+HOMEPAGE="https://github.com/Biosias/uefi-mkconfig"
+SRC_URI="https://github.com/Biosias/uefi-mkconfig/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-shells/bash
+ sys-boot/efibootmgr
+"
+
+CONFIG_CHECK="EFI_STUB"
+
+src_install() {
+ dobin uefi-mkconfig
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "uefi-mkconfig: Automatic management of UEFI entries"
+ elog "Run uefi-mkconfig while having all efi partitions mounted"
+ elog "Please use with care, this package was tested on a limited number of machines"
+ elog "Some problems may arise due to different implementations of UEFI"
+ elog
+ optfeature "Add UEFI entries on kernel installation " \ "sys-kernel/installkernel[-systemd,efistub]"
+}