summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-06-10 01:11:26 -0400
committerSam James <sam@gentoo.org>2024-06-14 07:44:41 +0100
commitc31ee12d006747270fa58e611aa42eb4f9dee663 (patch)
treec694fe80f127867ee26a2390a3da58a6c8bf302b /sys-cluster/pmix
parentdev-perl/Tk: further Modern C fixes (diff)
downloadgentoo-c31ee12d006747270fa58e611aa42eb4f9dee663.tar.gz
gentoo-c31ee12d006747270fa58e611aa42eb4f9dee663.tar.bz2
gentoo-c31ee12d006747270fa58e611aa42eb4f9dee663.zip
sys-cluster/pmix: make sure elibtoolize is applied, mark as LTO-unsafe
elibtoolize is needed to e.g. pass LTO warning flags through to the linker. And indeed, once that is used, the build starts failing with LTO error flags. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster/pmix')
-rw-r--r--sys-cluster/pmix/pmix-4.2.8.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/sys-cluster/pmix/pmix-4.2.8.ebuild b/sys-cluster/pmix/pmix-4.2.8.ebuild
index 313536a69a73..ce44f08ba0c0 100644
--- a/sys-cluster/pmix/pmix-4.2.8.ebuild
+++ b/sys-cluster/pmix/pmix-4.2.8.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit flag-o-matic libtool
+
DESCRIPTION="The Process Management Interface (PMI) Exascale"
HOMEPAGE="https://openpmix.github.io/"
SRC_URI="https://github.com/openpmix/openpmix/releases/download/v${PV}/${P}.tar.bz2"
@@ -23,7 +25,16 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://github.com/openpmix/openpmix/issues/3350
+ filter-lto
+
econf \
--disable-werror \
$(use_enable debug) \