summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-20 10:03:19 +0000
committerSam James <sam@gentoo.org>2023-12-20 10:03:29 +0000
commitcd296783cab97c794a2afb16c2049890ad357880 (patch)
tree286523566f009f2f9cb20a70462046721697ccb8 /sys-cluster/pmix
parentgui-libs/xdg-desktop-portal-wlr: add portal config file to 0.7.0-r1 (diff)
downloadgentoo-cd296783cab97c794a2afb16c2049890ad357880.tar.gz
gentoo-cd296783cab97c794a2afb16c2049890ad357880.tar.bz2
gentoo-cd296783cab97c794a2afb16c2049890ad357880.zip
sys-cluster/pmix: add 4.2.8
Bug: https://bugs.gentoo.org/914381 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster/pmix')
-rw-r--r--sys-cluster/pmix/Manifest1
-rw-r--r--sys-cluster/pmix/pmix-4.2.8.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/sys-cluster/pmix/Manifest b/sys-cluster/pmix/Manifest
index 0529b5573c01..720f2551e520 100644
--- a/sys-cluster/pmix/Manifest
+++ b/sys-cluster/pmix/Manifest
@@ -1 +1,2 @@
DIST pmix-4.2.2.tar.bz2 1639600 BLAKE2B b5109900e52750656200e7bdbdc39d870a01f5afc1fb622663dfb2c9647b1735c23ece906064b34923977c522fb5a89afc03d81b7d115b26337934ab5bfe7ce3 SHA512 b7cb1e2079d517b32fc5d99012a7c4b161c1509b3ac1e0ba7e4697f2fe0917455927d06c86ecab5f2fa6073e1f058e86260d2115b6f8cc968a43a5675439f28d
+DIST pmix-4.2.8.tar.bz2 4800886 BLAKE2B 49c6c74f2a3d4826ade004e2ca69f8adafb26232b8fe92f5e620e11f93bde6a84a3611e737818564a3a5fd6fb75a4819250fa038e55aab46cf0a29c3f04e9f7e SHA512 2bc78cda82af24a9d7db204684e1778e0db183acc425095a91d46e4253209cec06542d497d5502c502b946b0ed1517f3b34f532d1107ccac1a09f2f267f14089
diff --git a/sys-cluster/pmix/pmix-4.2.8.ebuild b/sys-cluster/pmix/pmix-4.2.8.ebuild
new file mode 100644
index 000000000000..313536a69a73
--- /dev/null
+++ b/sys-cluster/pmix/pmix-4.2.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="The Process Management Interface (PMI) Exascale"
+HOMEPAGE="https://openpmix.github.io/"
+SRC_URI="https://github.com/openpmix/openpmix/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+# No support for 32-bit systems as of 4.2.8 (https://github.com/open-mpi/ompi/issues/11248)
+KEYWORDS="~amd64 -x86 ~amd64-linux"
+IUSE="debug +munge pmi"
+
+RDEPEND="
+ dev-libs/libevent:=
+ sys-apps/hwloc:=
+ sys-cluster/ucx
+ sys-libs/zlib:=
+ munge? ( sys-auth/munge )
+ pmi? ( !sys-cluster/slurm )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable debug) \
+ $(use_with munge)
+}
+
+src_install() {
+ default
+
+ # bug #884765
+ mv "${ED}"/usr/bin/pquery "${ED}"/usr/bin/pmix-pquery || die
+}