summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-06-19 23:40:02 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-19 23:40:02 +0300
commit73e30c5978225448acd01601c960f9e809bb7a3e (patch)
treec013fecd437b69289f2a50a14190d7ac52e2d052 /sys-cluster/teleport
parentnet-analyzer/opsgenie-lamp: drop 2.5.1_p20181102 (diff)
downloadgentoo-73e30c5978225448acd01601c960f9e809bb7a3e.tar.gz
gentoo-73e30c5978225448acd01601c960f9e809bb7a3e.tar.bz2
gentoo-73e30c5978225448acd01601c960f9e809bb7a3e.zip
sys-cluster/teleport: drop stale 9999
This live ebuild depends on deprecated golang-vcs.eclass Bug: https://bugs.gentoo.org/844727 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-cluster/teleport')
-rw-r--r--sys-cluster/teleport/teleport-9999.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/sys-cluster/teleport/teleport-9999.ebuild b/sys-cluster/teleport/teleport-9999.ebuild
deleted file mode 100644
index a82f2fc86c92..000000000000
--- a/sys-cluster/teleport/teleport-9999.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit golang-build systemd
-
-DESCRIPTION="Modern SSH server for teams managing distributed infrastructure"
-HOMEPAGE="https://gravitational.com/teleport"
-
-EGO_PN="github.com/gravitational/${PN}/..."
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3 golang-vcs
- EGIT_REPO_URI="https://github.com/gravitational/${PN}.git"
-else
- inherit golang-vcs-snapshot
- SRC_URI="https://github.com/gravitational/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm"
-fi
-
-IUSE="pam"
-LICENSE="Apache-2.0 MIT BSD ISC"
-RESTRICT="test strip"
-SLOT="0"
-
-BDEPEND="app-arch/zip"
-RDEPEND="pam? ( sys-libs/pam )"
-
-src_compile() {
- BUILDFLAGS="" GOPATH="${S}" emake -j1 -C src/${EGO_PN%/*} full
-}
-
-src_install() {
- keepdir /var/lib/${PN} /etc/${PN}
- dobin src/${EGO_PN%/*}/build/{tsh,tctl,teleport}
-
- insinto /etc/${PN}
- doins "${FILESDIR}"/${PN}.yaml
-
- newinitd "${FILESDIR}"/${PN}.init.d ${PN}
- newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
-
- systemd_newunit "${FILESDIR}"/${PN}.service ${PN}.service
- systemd_install_serviced "${FILESDIR}"/${PN}.service.conf ${PN}.service
-}
-
-src_test() {
- BUILDFLAGS="" GOPATH="${S}" emake -C src/${EGO_PN%/*} test
-}