summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNHOrus <jy6x2b32pie9@yahoo.com>2024-04-04 17:19:02 +0400
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-04-04 16:26:17 +0200
commit05b289c9289d3099436883a6d936544390fb1fb8 (patch)
treedd8eff43922982c22b6d3012e1a9c0a266e52484 /sys-cluster
parentmedia-gfx/fotocx: add 24.21 (diff)
downloadgentoo-05b289c9289d3099436883a6d936544390fb1fb8.tar.gz
gentoo-05b289c9289d3099436883a6d936544390fb1fb8.tar.bz2
gentoo-05b289c9289d3099436883a6d936544390fb1fb8.zip
sys-cluster/ampi: Fix missing include
Closes: https://bugs.gentoo.org/881323 Signed-off-by: NHOrus <jy6x2b32pie9@yahoo.com> Closes: https://github.com/gentoo/gentoo/pull/36097 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ampi/ampi-0_pre20140616.ebuild4
-rw-r--r--sys-cluster/ampi/files/ampi-0_pre20140616-missing-include.patch10
2 files changed, 13 insertions, 1 deletions
diff --git a/sys-cluster/ampi/ampi-0_pre20140616.ebuild b/sys-cluster/ampi/ampi-0_pre20140616.ebuild
index 41f35f9e9bad..c441769df548 100644
--- a/sys-cluster/ampi/ampi-0_pre20140616.ebuild
+++ b/sys-cluster/ampi/ampi-0_pre20140616.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -16,6 +16,8 @@ KEYWORDS="amd64 arm ~arm64 ~hppa ~ia64 ~ppc ppc64 ~riscv ~sparc x86"
RDEPEND="virtual/mpi"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}"/"${P}"-missing-include.patch )
+
src_prepare() {
default
eautoreconf
diff --git a/sys-cluster/ampi/files/ampi-0_pre20140616-missing-include.patch b/sys-cluster/ampi/files/ampi-0_pre20140616-missing-include.patch
new file mode 100644
index 000000000000..0e9452877728
--- /dev/null
+++ b/sys-cluster/ampi/files/ampi-0_pre20140616-missing-include.patch
@@ -0,0 +1,10 @@
+--- a/ADtoolStubs/OO/support.c 2024-04-04 13:10:23.506762461 +0000
++++ b/ADtoolStubs/OO/support.c 2024-04-04 13:11:34.033298264 +0000
+@@ -8,6 +8,7 @@
+ */
+ #include <stdlib.h>
+ #include <assert.h>
++#include <stdio.h>
+ #include "ampi/adTool/support.h"
+
+ MPI_Comm ADTOOL_AMPI_COMM_WORLD_SHADOW;