summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-01-16 14:50:08 +0100
committerMichał Górny <mgorny@gentoo.org>2019-01-16 15:52:31 +0100
commitcb04d7aa5f5705f059b851cb1659d3dba466cbf7 (patch)
treeac764aa15ef32e6ba2eb79e5c725b4aacf7591bf /sys-devel/clang-common
parentsys-devel/lld: Add a live ebuild for 8.* branch (diff)
downloadgentoo-cb04d7aa5f5705f059b851cb1659d3dba466cbf7.tar.gz
gentoo-cb04d7aa5f5705f059b851cb1659d3dba466cbf7.tar.bz2
gentoo-cb04d7aa5f5705f059b851cb1659d3dba466cbf7.zip
sys-devel/clang-common: Add a live ebuild for 8.* branch
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-common')
-rw-r--r--sys-devel/clang-common/clang-common-8.0.9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-devel/clang-common/clang-common-8.0.9999.ebuild b/sys-devel/clang-common/clang-common-8.0.9999.ebuild
new file mode 100644
index 000000000000..c412694e6d73
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-8.0.9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 git-r3
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/clang.git
+ https://github.com/llvm-mirror/clang.git"
+EGIT_BRANCH="release_80"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' utils/bash-autocomplete.sh
+}
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ newbashcomp utils/bash-autocomplete.sh clang
+}