summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-05 21:48:33 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-05 21:49:51 +0200
commitdd6144c384755d5b523bd6b096d5fffaf3a714bb (patch)
tree431efdf9de1f5855668a4ddd35ffb85ed77be1d8 /sys-devel/clang-common
parentdev-ml/llvm-ocaml: Add 16.* live ebuilds (diff)
downloadgentoo-dd6144c384755d5b523bd6b096d5fffaf3a714bb.tar.gz
gentoo-dd6144c384755d5b523bd6b096d5fffaf3a714bb.tar.bz2
gentoo-dd6144c384755d5b523bd6b096d5fffaf3a714bb.zip
sys-devel/clang-common: Add 16.* live ebuilds
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-common')
-rw-r--r--sys-devel/clang-common/clang-common-16.0.0.9999.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
new file mode 100644
index 000000000000..1285500128bb
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+
+PDEPEND="
+ sys-devel/clang:*
+"
+
+LLVM_COMPONENTS=( clang/utils )
+llvm.org_set_globals
+
+src_install() {
+ newbashcomp bash-autocomplete.sh clang
+}