summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-24 02:58:45 +0100
committerSam James <sam@gentoo.org>2023-10-24 02:58:45 +0100
commit2a19a95aaa27610e6aa81713d31912578dc9ff5a (patch)
tree9869c6a8194015d59cb1d9f80c65c4a14300adc6 /sys-devel/gcc
parentsys-libs/fortify-headers: wire up tests (diff)
downloadgentoo-2a19a95aaa27610e6aa81713d31912578dc9ff5a.tar.gz
gentoo-2a19a95aaa27610e6aa81713d31912578dc9ff5a.tar.bz2
gentoo-2a19a95aaa27610e6aa81713d31912578dc9ff5a.zip
sys-devel/gcc: backport vectorisation ICE fix for gcc 14
Bug: https://gcc.gnu.org/PR111860 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/gcc')
-rw-r--r--sys-devel/gcc/files/gcc-14.0.0_pre20231022-PR111860.patch129
-rw-r--r--sys-devel/gcc/gcc-14.0.0_pre20231022-r1.ebuild65
2 files changed, 194 insertions, 0 deletions
diff --git a/sys-devel/gcc/files/gcc-14.0.0_pre20231022-PR111860.patch b/sys-devel/gcc/files/gcc-14.0.0_pre20231022-PR111860.patch
new file mode 100644
index 000000000000..42deb046d0f3
--- /dev/null
+++ b/sys-devel/gcc/files/gcc-14.0.0_pre20231022-PR111860.patch
@@ -0,0 +1,129 @@
+https://gcc.gnu.org/PR111860
+https://gcc.gnu.org/git/gitweb.cgi?p=gcc.git;h=9ed6b22eb4188c57bb3f5cdba5a7effa95395186
+
+From 9ed6b22eb4188c57bb3f5cdba5a7effa95395186 Mon Sep 17 00:00:00 2001
+From: Tamar Christina <tamar.christina@arm.com>
+Date: Mon, 23 Oct 2023 14:07:20 +0100
+Subject: [PATCH] middle-end: don't keep .MEM guard nodes for PHI nodes who
+ dominate loop [PR111860]
+
+The previous patch tried to remove PHI nodes that dominated the first loop,
+however the correct fix is to only remove .MEM nodes.
+
+This patch thus makes the condition a bit stricter and only tries to remove
+MEM phi nodes.
+
+I couldn't figure out a way to easily determine if a particular PHI is vUSE
+related, so the patch does:
+
+1. check if the definition is a vDEF and not defined in main loop.
+2. check if the definition is a PHI and not defined in main loop.
+3. check if the definition is a default definition.
+
+For no 2 and 3 we may misidentify the PHI, in both cases the value is defined
+outside of the loop version block which also makes it ok to remove.
+
+gcc/ChangeLog:
+
+ PR tree-optimization/111860
+ * tree-vect-loop-manip.cc (slpeel_tree_duplicate_loop_to_edge_cfg):
+ Drop .MEM nodes only.
+
+gcc/testsuite/ChangeLog:
+
+ PR tree-optimization/111860
+ * gcc.dg/vect/pr111860-2.c: New test.
+ * gcc.dg/vect/pr111860-3.c: New test.
+---
+ gcc/testsuite/gcc.dg/vect/pr111860-2.c | 17 +++++++++++++++++
+ gcc/testsuite/gcc.dg/vect/pr111860-3.c | 17 +++++++++++++++++
+ gcc/tree-vect-loop-manip.cc | 21 ++++++++++++++++++++-
+ 3 files changed, 54 insertions(+), 1 deletion(-)
+ create mode 100644 gcc/testsuite/gcc.dg/vect/pr111860-2.c
+ create mode 100644 gcc/testsuite/gcc.dg/vect/pr111860-3.c
+
+diff --git a/gcc/testsuite/gcc.dg/vect/pr111860-2.c b/gcc/testsuite/gcc.dg/vect/pr111860-2.c
+new file mode 100644
+index 000000000000..07f64ffb5318
+--- /dev/null
++++ b/gcc/testsuite/gcc.dg/vect/pr111860-2.c
+@@ -0,0 +1,17 @@
++/* { dg-do compile } */
++/* { dg-options "-O -fno-tree-sink -ftree-vectorize" } */
++int buffer_ctrl_ctx_0, buffer_ctrl_p1, buffer_ctrl_cmd;
++
++int
++buffer_ctrl (long ret, int i)
++{
++ switch (buffer_ctrl_cmd)
++ {
++ case 1:
++ buffer_ctrl_ctx_0 = 0;
++ for (; i; i++)
++ if (buffer_ctrl_p1)
++ ret++;
++ }
++ return ret;
++}
+diff --git a/gcc/testsuite/gcc.dg/vect/pr111860-3.c b/gcc/testsuite/gcc.dg/vect/pr111860-3.c
+new file mode 100644
+index 000000000000..07f64ffb5318
+--- /dev/null
++++ b/gcc/testsuite/gcc.dg/vect/pr111860-3.c
+@@ -0,0 +1,17 @@
++/* { dg-do compile } */
++/* { dg-options "-O -fno-tree-sink -ftree-vectorize" } */
++int buffer_ctrl_ctx_0, buffer_ctrl_p1, buffer_ctrl_cmd;
++
++int
++buffer_ctrl (long ret, int i)
++{
++ switch (buffer_ctrl_cmd)
++ {
++ case 1:
++ buffer_ctrl_ctx_0 = 0;
++ for (; i; i++)
++ if (buffer_ctrl_p1)
++ ret++;
++ }
++ return ret;
++}
+diff --git a/gcc/tree-vect-loop-manip.cc b/gcc/tree-vect-loop-manip.cc
+index d67c94700144..43ca985c53ce 100644
+--- a/gcc/tree-vect-loop-manip.cc
++++ b/gcc/tree-vect-loop-manip.cc
+@@ -1626,12 +1626,31 @@ slpeel_tree_duplicate_loop_to_edge_cfg (class loop *loop, edge loop_exit,
+ edge temp_e = redirect_edge_and_branch (exit, new_preheader);
+ flush_pending_stmts (temp_e);
+ }
+-
+ /* Record the new SSA names in the cache so that we can skip materializing
+ them again when we fill in the rest of the LCSSA variables. */
+ for (auto phi : new_phis)
+ {
+ tree new_arg = gimple_phi_arg (phi, 0)->def;
++
++ if (!SSA_VAR_P (new_arg))
++ continue;
++ /* If the PHI MEM node dominates the loop then we shouldn't create
++ a new LC-SSSA PHI for it in the intermediate block. */
++ /* A MEM phi that consitutes a new DEF for the vUSE chain can either
++ be a .VDEF or a PHI that operates on MEM. And said definition
++ must not be inside the main loop. Or we must be a parameter.
++ In the last two cases we may remove a non-MEM PHI node, but since
++ they dominate both loops the removal is unlikely to cause trouble
++ as the exits must already be using them. */
++ if (virtual_operand_p (new_arg)
++ && (SSA_NAME_IS_DEFAULT_DEF (new_arg)
++ || !flow_bb_inside_loop_p (loop,
++ gimple_bb (SSA_NAME_DEF_STMT (new_arg)))))
++ {
++ auto gsi = gsi_for_stmt (phi);
++ remove_phi_node (&gsi, true);
++ continue;
++ }
+ new_phi_args.put (new_arg, gimple_phi_result (phi));
+
+ if (TREE_CODE (new_arg) != SSA_NAME)
+--
+2.39.3
diff --git a/sys-devel/gcc/gcc-14.0.0_pre20231022-r1.ebuild b/sys-devel/gcc/gcc-14.0.0_pre20231022-r1.ebuild
new file mode 100644
index 000000000000..568120f07c07
--- /dev/null
+++ b/sys-devel/gcc/gcc-14.0.0_pre20231022-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+TOOLCHAIN_PATCH_DEV="sam"
+PATCH_GCC_VER="14.0.0"
+PATCH_VER="6"
+MUSL_VER="1"
+MUSL_GCC_VER="14.0.0"
+
+if [[ ${PV} == *.9999 ]] ; then
+ MY_PV_2=$(ver_cut 2)
+ MY_PV_3=1
+ if [[ ${MY_PV_2} == 0 ]] ; then
+ MY_PV_2=0
+ MY_PV_3=0
+ else
+ MY_PV_2=$((${MY_PV_2} - 1))
+ fi
+
+ # e.g. 12.2.9999 -> 12.1.1
+ TOOLCHAIN_GCC_PV=$(ver_cut 1).${MY_PV_2}.${MY_PV_3}
+elif [[ -n ${TOOLCHAIN_GCC_RC} ]] ; then
+ # Cheesy hack for RCs
+ MY_PV=$(ver_cut 1).$((($(ver_cut 2) + 1))).$((($(ver_cut 3) - 1)))-RC-$(ver_cut 5)
+ MY_P=${PN}-${MY_PV}
+ GCC_TARBALL_SRC_URI="mirror://gcc/snapshots/${MY_PV}/${MY_P}.tar.xz"
+ TOOLCHAIN_SET_S=no
+ S="${WORKDIR}"/${MY_P}
+fi
+
+inherit toolchain
+
+if tc_is_live ; then
+ # Needs to be after inherit (for now?), bug #830908
+ EGIT_BRANCH=master
+elif [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
+ # Don't keyword live ebuilds
+ #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ :;
+fi
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ # Technically only if USE=hardened *too* right now, but no point in complicating it further.
+ # If GCC is enabling CET by default, we need glibc to be built with support for it.
+ # bug #830454
+ RDEPEND="elibc_glibc? ( sys-libs/glibc[cet(-)?] )"
+ DEPEND="${RDEPEND}"
+ BDEPEND=">=${CATEGORY}/binutils-2.30[cet(-)?]"
+fi
+
+src_prepare() {
+ local p upstreamed_patches=(
+ # add them here
+ )
+ for p in "${upstreamed_patches[@]}"; do
+ rm -v "${WORKDIR}/patch/${p}" || die
+ done
+
+ toolchain_src_prepare
+
+ eapply "${FILESDIR}"/${P}-PR111860.patch
+ eapply_user
+}