summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-20 13:13:37 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-20 13:17:46 +0200
commit3d47ca4f047bc0ded5dc9f624beef421e5e0e678 (patch)
tree660d58c603b854a331842fc9a5a1307b7b617acf /sys-devel/lld-toolchain-symlinks
parentsys-devel/llvm-toolchain-symlinks: Add for LLVM 15.x (diff)
downloadgentoo-3d47ca4f047bc0ded5dc9f624beef421e5e0e678.tar.gz
gentoo-3d47ca4f047bc0ded5dc9f624beef421e5e0e678.tar.bz2
gentoo-3d47ca4f047bc0ded5dc9f624beef421e5e0e678.zip
sys-devel/lld-toolchain-symlinks: Add for LLVM 15.x
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/lld-toolchain-symlinks')
-rw-r--r--sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-15.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-15.ebuild b/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-15.ebuild
new file mode 100644
index 000000000000..75ee3dd007f7
--- /dev/null
+++ b/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-15.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib
+
+DESCRIPTION="Symlinks to use LLD on binutils-free system"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:LLVM"
+SRC_URI=""
+S=${WORKDIR}
+
+LICENSE="public-domain"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+native-symlinks"
+
+RDEPEND="
+ sys-devel/lld
+"
+
+src_install() {
+ use native-symlinks || return
+
+ local abi
+ local dest=/usr/lib/llvm/${SLOT}/bin
+ dodir "${dest}"
+ dosym ../../../../bin/ld.lld "${dest}/ld"
+ for abi in $(get_all_abis); do
+ local abi_chost=$(get_abi_CHOST "${abi}")
+ dosym ../../../../bin/ld.lld "${dest}/${abi_chost}-ld"
+ done
+}