summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-25 18:09:30 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-25 18:11:19 +0200
commitdbc2161518a325b74318a52478f6ac092aa4b813 (patch)
tree698b46b8b2a66b7b92d1210ecabeb82c7a58d2fb /sys-devel/llvm-common
parentsys-devel/llvm: master → main (diff)
downloadgentoo-dbc2161518a325b74318a52478f6ac092aa4b813.tar.gz
gentoo-dbc2161518a325b74318a52478f6ac092aa4b813.tar.bz2
gentoo-dbc2161518a325b74318a52478f6ac092aa4b813.zip
sys-devel/llvm-common: Add 18.x live ebuilds
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/llvm-common')
-rw-r--r--sys-devel/llvm-common/llvm-common-18.0.0.9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-18.0.0.9999.ebuild b/sys-devel/llvm-common/llvm-common-18.0.0.9999.ebuild
new file mode 100644
index 000000000000..ce5f03ca34a5
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-18.0.0.9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ !sys-devel/llvm:0
+"
+
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}