summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2024-03-03 21:20:54 +0000
committerSam James <sam@gentoo.org>2024-03-04 02:21:09 +0000
commitafcd5aa47776265486ddaa6ca2adcd8480b32574 (patch)
treeddff9f8f4db107d9beac78a50b302e4a10bee8ce /sys-devel/llvm/llvm-17.0.6.ebuild
parentsys-libs/zlib: respect AR on darwin (diff)
downloadgentoo-afcd5aa47776265486ddaa6ca2adcd8480b32574.tar.gz
gentoo-afcd5aa47776265486ddaa6ca2adcd8480b32574.tar.bz2
gentoo-afcd5aa47776265486ddaa6ca2adcd8480b32574.zip
sys-devel/llvm: use correct libtool on macos prefix
Bug: https://bugs.gentoo.org/924839 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/35613 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/llvm/llvm-17.0.6.ebuild')
-rw-r--r--sys-devel/llvm/llvm-17.0.6.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-devel/llvm/llvm-17.0.6.ebuild b/sys-devel/llvm/llvm-17.0.6.ebuild
index 8a87d9e2e08f..c5159086d72c 100644
--- a/sys-devel/llvm/llvm-17.0.6.ebuild
+++ b/sys-devel/llvm/llvm-17.0.6.ebuild
@@ -439,11 +439,13 @@ multilib_src_configure() {
)
fi
- # On Macos prefix, Gentoo doesn't split sys-libs/ncurses to libtinfo and
- # libncurses, but llvm tries to use libtinfo before libncurses, and ends up
- # using libtinfo (actually, libncurses.dylib) from system instead of prefix
use kernel_Darwin && mycmakeargs+=(
+ # On Macos prefix, Gentoo doesn't split sys-libs/ncurses to libtinfo and
+ # libncurses, but llvm tries to use libtinfo before libncurses, and ends up
+ # using libtinfo (actually, libncurses.dylib) from system instead of prefix
-DTerminfo_LIBRARIES=-lncurses
+ # Use our libtool instead of looking it up with xcrun
+ -DCMAKE_LIBTOOL="${EPREFIX}/usr/bin/${CHOST}-libtool"
)
# LLVM can have very high memory consumption while linking,