summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-10 04:55:13 +0100
committerSam James <sam@gentoo.org>2022-09-10 04:56:54 +0100
commit3e8c12159bc7298cf4bb4057bfd197f98713da28 (patch)
treeead5561bc7fcfb2607ac7a750e825df5a7205289 /sys-devel
parentprofiles/features/clang: update environment variables (diff)
downloadgentoo-3e8c12159bc7298cf4bb4057bfd197f98713da28.tar.gz
gentoo-3e8c12159bc7298cf4bb4057bfd197f98713da28.tar.bz2
gentoo-3e8c12159bc7298cf4bb4057bfd197f98713da28.zip
sys-devel/gcc: keyword 11.3.1_p20220909
Notably contains fixes for PPC which may cause crashes at runtime. Had come across this bug and a few others when poking at Clang build failure on PPC (bug 829602), although it doesn't seem to have fixed that (tagging bug anyway as it's possibly related in some form). I've been tempted to keyword a newer 11 stable snapshot for a while but didn't feel comfortable doing so until bug 834845 was resolved (info page/docs issue). Bug: https://bugs.gentoo.org/829602 Bug: https://bugs.gentoo.org/834845 Bug: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104090 See: https://github.com/buildroot/buildroot/commit/b42c6b24755170a8eb015b3ea0b25e6d91e037cb Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-11.3.1_p20220909.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-devel/gcc/gcc-11.3.1_p20220909.ebuild b/sys-devel/gcc/gcc-11.3.1_p20220909.ebuild
index 79b1ee62b754..e821929d61b4 100644
--- a/sys-devel/gcc/gcc-11.3.1_p20220909.ebuild
+++ b/sys-devel/gcc/gcc-11.3.1_p20220909.ebuild
@@ -27,9 +27,9 @@ inherit toolchain
EGIT_BRANCH=releases/gcc-$(ver_cut 1)
# Don't keyword live ebuilds
-#if ! tc_is_live && [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
-# KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-#fi
+if ! tc_is_live && [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
# Technically only if USE=hardened *too* right now, but no point in complicating it further.
# If GCC is enabling CET by default, we need glibc to be built with support for it.