summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-14 20:55:10 +0100
committerSam James <sam@gentoo.org>2021-10-14 20:55:43 +0100
commit60373435af6039609ab613bffa4c3efcd6557689 (patch)
tree700409dd4b4a46b537c59fca3a4fba69e1b93a59 /sys-devel
parentdev-util/cmake: Removed old (diff)
downloadgentoo-60373435af6039609ab613bffa4c3efcd6557689.tar.gz
gentoo-60373435af6039609ab613bffa4c3efcd6557689.tar.bz2
gentoo-60373435af6039609ab613bffa4c3efcd6557689.zip
sys-devel/gcc: add 9.4.1_pre9999
If it happens, it'll probably be 9.5(?), but in any case, this is useful for testing out bugs. Bug: https://bugs.gentoo.org/806094 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-9.4.1_pre9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-9.4.1_pre9999.ebuild b/sys-devel/gcc/gcc-9.4.1_pre9999.ebuild
new file mode 100644
index 000000000000..8c31f450a34c
--- /dev/null
+++ b/sys-devel/gcc/gcc-9.4.1_pre9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PATCH_GCC_VER="9.4.0"
+PATCH_VER="1"
+
+inherit toolchain
+
+# Don't keyword live ebuilds
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+
+RDEPEND=""
+BDEPEND="${CATEGORY}/binutils"
+
+src_prepare() {
+ local p upstreamed_patches=(
+ # add them here
+ )
+ for p in "${upstreamed_patches[@]}"; do
+ rm -v "${WORKDIR}/patch/${p}" || die
+ done
+
+ toolchain_src_prepare
+}