summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-07 17:20:57 +0100
committerSam James <sam@gentoo.org>2024-06-07 17:26:47 +0100
commit6788373d9c16f58622351c2ee91e9f4f3d07a7cb (patch)
tree388d47066a5f22de5c91434f6a651dea7a889235 /sys-fs
parentdev-java/javatoolkit: add setuptools dep (diff)
downloadgentoo-6788373d9c16f58622351c2ee91e9f4f3d07a7cb.tar.gz
gentoo-6788373d9c16f58622351c2ee91e9f4f3d07a7cb.tar.bz2
gentoo-6788373d9c16f58622351c2ee91e9f4f3d07a7cb.zip
sys-fs/e2fsprogs: add 1.47.1
Adds libarchive support, see 7e3a4f0a33e9859af2bf44e8e1e278c8b10313cc upstream. Closes: https://bugs.gentoo.org/908892 Closes: https://bugs.gentoo.org/916029 Bug: https://bugs.gentoo.org/896340 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/e2fsprogs/Manifest1
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.47.1.ebuild167
-rw-r--r--sys-fs/e2fsprogs/metadata.xml1
3 files changed, 169 insertions, 0 deletions
diff --git a/sys-fs/e2fsprogs/Manifest b/sys-fs/e2fsprogs/Manifest
index 5e61ba790588..158350ccca80 100644
--- a/sys-fs/e2fsprogs/Manifest
+++ b/sys-fs/e2fsprogs/Manifest
@@ -1 +1,2 @@
DIST e2fsprogs-1.47.0.tar.xz 7059372 BLAKE2B 84f58b05a9f0e14e1a66c6e5171ff23b022f51c4e9a02d4d6d1d26c91909f3c7ec9c9f0462663a4457b4479043774502b8891f691e58a61f4ef6bf9ba33f33aa SHA512 0e6d64c565b455becb84166b6a5c7090724bac5cfe69098657a31bf0481b4e2cace3de1363121b7d84820fbae85b7c83ac5f2a2b02bb36280f0e3ae83a934cec
+DIST e2fsprogs-1.47.1.tar.xz 7271444 BLAKE2B 67924c38a6b688e0db5ee77b0e11a8b34ec602a729d48516668e9fdf7f36964c8a9369295f0313bfacdc8e5f3f5a27d79a8d99a1aca3b4fe0ced98a4db4884ea SHA512 2ac51f7654a44adf3ee5a5e32cecd7f129e423bdf3074c60b22a7acdba131e7dd0bb2964c107a06ae133f51836272be166f5da1f996f67ceb6c22e2636117beb
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.47.1.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.47.1.ebuild
new file mode 100644
index 000000000000..300fe7548c64
--- /dev/null
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.47.1.ebuild
@@ -0,0 +1,167 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal systemd toolchain-funcs udev
+
+DESCRIPTION="Standard EXT2/EXT3/EXT4 filesystem utilities"
+HOMEPAGE="http://e2fsprogs.sourceforge.net/"
+SRC_URI="https://www.kernel.org/pub/linux/kernel/people/tytso/e2fsprogs/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="archive cron fuse nls static-libs test +tools"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !sys-libs/${PN}-libs
+ archive? ( app-arch/libarchive:= )
+ cron? ( sys-fs/lvm2[lvm] )
+ fuse? ( sys-fs/fuse:3 )
+ nls? ( virtual/libintl )
+ tools? ( sys-apps/util-linux )
+"
+# For testing lib/ext2fs, lib/support/libsupport.a is required, which
+# unconditionally includes '<blkid/blkid.h>' from sys-apps/util-linux.
+DEPEND="
+ ${RDEPEND}
+ test? ( sys-apps/util-linux[${MULTILIB_USEDEP}] )
+"
+BDEPEND="
+ sys-apps/texinfo
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/ext2fs/ext2_types.h
+)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.42.13-fix-build-cflags.patch # bug #516854
+ # We can drop this metadata patch after 6 months or so to let initramfses
+ # upgrade. See bug #904093 and bug #904048.
+ "${FILESDIR}"/${PN}-1.47.0-disable-metadata_csum_seed-and-orphan_file-by-default.patch
+
+ # Upstream patches (can usually removed with next version bump)
+)
+
+src_prepare() {
+ default
+
+ cp doc/RelNotes/v${PV}.txt ChangeLog || die "Failed to copy Release Notes"
+
+ # Get rid of doc -- we don't use them. This also prevents a sandbox
+ # violation due to mktexfmt invocation
+ rm -r doc || die "Failed to remove doc dir"
+
+ # Prevent included intl cruft from building, bug #81096
+ sed -i -r \
+ -e 's:@LIBINTL@:@LTLIBINTL@:' \
+ MCONFIG.in || die 'intl cruft'
+}
+
+multilib_src_configure() {
+ # Keep the package from doing silly things, bug #261411
+ export VARTEXFONTS="${T}/fonts"
+
+ local myeconfargs=(
+ --with-root-prefix="${EPREFIX}"
+ $(use_with cron crond-dir "${EPREFIX}/etc/cron.d")
+ --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
+ --with-udev-rules-dir="${EPREFIX}$(get_udevdir)/rules.d"
+ --enable-symlink-install
+ --enable-elf-shlibs
+ $(tc-has-tls || echo --disable-tls)
+ $(multilib_native_use_with archive libarchive direct)
+ $(multilib_native_use_enable fuse fuse2fs)
+ $(use_enable nls)
+ $(multilib_native_use_enable tools e2initrd-helper)
+ --disable-fsck
+ --disable-uuidd
+ --disable-lto
+ --with-pthread
+ --enable-largefile
+ )
+
+ # We use blkid/uuid from util-linux now
+ if use kernel_linux ; then
+ export ac_cv_lib_{uuid_uuid_generate,blkid_blkid_get_cache}=yes
+ myeconfargs+=( --disable-lib{blkid,uuid} )
+ fi
+
+ ac_cv_path_LDCONFIG=: \
+ ECONF_SOURCE="${S}" \
+ CC="$(tc-getCC)" \
+ BUILD_CC="$(tc-getBUILD_CC)" \
+ BUILD_LD="$(tc-getBUILD_LD)" \
+ econf "${myeconfargs[@]}"
+
+ if grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
+ eerror "INTL sanity check failed, aborting build."
+ eerror "Please post your ${S}/config.log file as an"
+ eerror "attachment to https://bugs.gentoo.org/81096"
+ die "Preventing included intl cruft from building"
+ fi
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi && use tools ; then
+ emake V=1
+ else
+ emake -C lib/et V=1
+ emake -C lib/ss V=1
+ emake -C lib/ext2fs V=1
+ emake -C lib/e2p V=1
+ fi
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi && use tools ; then
+ emake V=1 check
+ else
+ # Required by lib/ext2fs's check target
+ emake -C lib/support V=1
+
+ # For non-native, there's no binaries to test. Just libraries.
+ emake -C lib/et V=1 check
+ emake -C lib/ss V=1 check
+ emake -C lib/ext2fs V=1 check
+ emake -C lib/e2p V=1 check
+ fi
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi && use tools ; then
+ emake STRIP=':' V=1 DESTDIR="${D}" install
+ else
+ emake -C lib/et V=1 DESTDIR="${D}" install
+ emake -C lib/ss V=1 DESTDIR="${D}" install
+ emake -C lib/ext2fs V=1 DESTDIR="${D}" install
+ emake -C lib/e2p V=1 DESTDIR="${D}" install
+ fi
+
+ # configure doesn't have an option to disable static libs
+ if ! use static-libs ; then
+ find "${ED}" -name '*.a' -delete || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use tools ; then
+ insinto /etc
+ doins "${FILESDIR}"/e2fsck.conf
+ fi
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/sys-fs/e2fsprogs/metadata.xml b/sys-fs/e2fsprogs/metadata.xml
index 3030299059ee..972d0ac8f30c 100644
--- a/sys-fs/e2fsprogs/metadata.xml
+++ b/sys-fs/e2fsprogs/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Base System</name>
</maintainer>
<use>
+ <flag name="archive">Add support for mke2fs to read a tarball as input. This allows not needing privileges. Needs <pkg>app-arch/libarchive</pkg>.</flag>
<flag name="cron">Install e2scrub_all cron script</flag>
<flag name="fuse">Build fuse2fs, a FUSE file system client for ext2/ext3/ext4 file systems</flag>
<flag name="tools">Build extfs tools (mke2fs, e2fsck, tune2fs, etc.)</flag>