summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-09-19 17:35:46 -0400
committerMike Gilbert <floppym@gentoo.org>2021-09-19 17:36:25 -0400
commit9b09f0646011091f3a3af4259e12dfdafcfbceed (patch)
tree8e1dbf7c4f2efb5df14afaef7c11c2b74aa68953 /sys-fs
parentmedia-libs/smpeg: amd64 stable wrt bug #813777 (diff)
downloadgentoo-9b09f0646011091f3a3af4259e12dfdafcfbceed.tar.gz
gentoo-9b09f0646011091f3a3af4259e12dfdafcfbceed.tar.bz2
gentoo-9b09f0646011091f3a3af4259e12dfdafcfbceed.zip
sys-fs/lvm2: skip tmpfiles when USE=device-mapper-only
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/lvm2/lvm2-2.02.188-r2.ebuild6
-rw-r--r--sys-fs/lvm2/lvm2-2.03.13-r2.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/sys-fs/lvm2/lvm2-2.02.188-r2.ebuild b/sys-fs/lvm2/lvm2-2.02.188-r2.ebuild
index a6c786adcc2d..2ed5a5019a96 100644
--- a/sys-fs/lvm2/lvm2-2.02.188-r2.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.188-r2.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+TMPFILES_OPTIONAL=1
inherit autotools linux-info multilib systemd toolchain-funcs tmpfiles udev flag-o-matic
DESCRIPTION="User-land utilities for LVM2 (device-mapper) software"
@@ -36,6 +37,7 @@ RDEPEND="${DEPEND_COMMON}
!!sys-fs/lvm-user
>=sys-apps/util-linux-2.16
lvm2create_initrd? ( sys-apps/makedev )
+ !device-mapper-only? ( virtual/tmpfiles )
thin? ( >=sys-block/thin-provisioning-tools-0.3.0 )"
# note: thin- 0.3.0 is required to avoid --disable-thin_check_needs_check
DEPEND="${DEPEND_COMMON}
@@ -265,7 +267,9 @@ src_install() {
}
pkg_postinst() {
- tmpfiles_process lvm2.conf
+ if ! use device-mapper-only; then
+ tmpfiles_process lvm2.conf
+ fi
if [[ -z "${REPLACING_VERSIONS}" ]]; then
# This is a new installation
diff --git a/sys-fs/lvm2/lvm2-2.03.13-r2.ebuild b/sys-fs/lvm2/lvm2-2.03.13-r2.ebuild
index f6c64e6f5d1b..416cccb8fd29 100644
--- a/sys-fs/lvm2/lvm2-2.03.13-r2.ebuild
+++ b/sys-fs/lvm2/lvm2-2.03.13-r2.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+TMPFILES_OPTIONAL=1
inherit autotools linux-info multilib systemd toolchain-funcs tmpfiles udev flag-o-matic
DESCRIPTION="User-land utilities for LVM2 (device-mapper) software"
@@ -36,6 +37,7 @@ RDEPEND="${DEPEND_COMMON}
!!sys-fs/lvm-user
>=sys-apps/util-linux-2.16
lvm2create_initrd? ( sys-apps/makedev )
+ !device-mapper-only? ( virtual/tmpfiles )
thin? ( >=sys-block/thin-provisioning-tools-0.3.0 )"
# note: thin- 0.3.0 is required to avoid --disable-thin_check_needs_check
DEPEND="${DEPEND_COMMON}
@@ -253,7 +255,9 @@ src_install() {
}
pkg_postinst() {
- tmpfiles_process lvm2.conf
+ if ! use device-mapper-only; then
+ tmpfiles_process lvm2.conf
+ fi
if [[ -z "${REPLACING_VERSIONS}" ]]; then
# This is a new installation