summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2025-01-23 10:13:41 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2025-01-23 10:13:41 +0100
commit57d2235b3ecfad50f717c6aa5f625385266cd955 (patch)
tree15b7b5f9f6acf7ffbfd3b44a557d32c78e8f281f /sys-libs
parentRevert "sys-libs/glibc: copy libgcc_s.so.1 into testdir (needed e.g. for arm)" (diff)
downloadgentoo-57d2235b3ecfad50f717c6aa5f625385266cd955.tar.gz
gentoo-57d2235b3ecfad50f717c6aa5f625385266cd955.tar.bz2
gentoo-57d2235b3ecfad50f717c6aa5f625385266cd955.zip
sys-libs/glibc: Fix cross-compiling glibc when clang is selected
Was accidentally dropped in -r8 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.40-r8.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/glibc/glibc-2.40-r8.ebuild b/sys-libs/glibc/glibc-2.40-r8.ebuild
index a04a45bd8cbf..181d92fc3d5b 100644
--- a/sys-libs/glibc/glibc-2.40-r8.ebuild
+++ b/sys-libs/glibc/glibc-2.40-r8.ebuild
@@ -609,13 +609,13 @@ setup_env() {
# Last, we need the settings of the *build* environment, not of the
# target environment...
- local current_binutils_path=$(env ROOT="${BROOT}" binutils-config -B)
+ local current_binutils_path=$(env CHOST="${CBUILD}" ROOT="${BROOT}" binutils-config -B "${CTARGET}")
local current_gcc_path=$(env ROOT="${BROOT}" gcc-config -B)
einfo "Overriding clang configuration, since it won't work here"
- export CC="${current_gcc_path}/gcc"
- export CPP="${current_gcc_path}/cpp"
- export CXX="${current_gcc_path}/g++"
+ export CC="${current_gcc_path}/${CTARGET}-gcc"
+ export CPP="${current_gcc_path}/${CTARGET}-cpp"
+ export CXX="${current_gcc_path}/${CTARGET}-g++"
export LD="${current_binutils_path}/ld.bfd"
export AR="${current_binutils_path}/ar"
export AS="${current_binutils_path}/as"