summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-18 16:15:32 +0100
committerSam James <sam@gentoo.org>2022-06-18 16:15:38 +0100
commit764b9be6851658364f4163ce9df3edc34dba9ee3 (patch)
tree1f4b8066b1e22e851a9e021a32f4d28f0bdf8fd5 /sys-libs
parentdev-lang/hy: Add py3.10 support (diff)
downloadgentoo-764b9be6851658364f4163ce9df3edc34dba9ee3.tar.gz
gentoo-764b9be6851658364f4163ce9df3edc34dba9ee3.tar.bz2
gentoo-764b9be6851658364f4163ce9df3edc34dba9ee3.zip
sys-libs/libxcrypt: disable LTO
Closes: https://bugs.gentoo.org/852917 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libxcrypt/libxcrypt-4.4.28-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-libs/libxcrypt/libxcrypt-4.4.28-r1.ebuild b/sys-libs/libxcrypt/libxcrypt-4.4.28-r1.ebuild
index dbab827b3def..00bcffbd2ef4 100644
--- a/sys-libs/libxcrypt/libxcrypt-4.4.28-r1.ebuild
+++ b/sys-libs/libxcrypt/libxcrypt-4.4.28-r1.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{8..10} )
# NEED_BOOTSTRAP is for developers to quickly generate a tarball
# for publishing to the tree.
NEED_BOOTSTRAP="no"
-inherit eapi8-dosym multibuild multilib python-any-r1 toolchain-funcs multilib-minimal
+inherit eapi8-dosym multibuild multilib python-any-r1 flag-o-matic toolchain-funcs multilib-minimal
DESCRIPTION="Extended crypt library for descrypt, md5crypt, bcrypt, and others"
HOMEPAGE="https://github.com/besser82/libxcrypt"
@@ -123,6 +123,10 @@ src_configure() {
# bug #821496
tc-ld-disable-gold
+ # Doesn't work with LTO: bug #852917.
+ # https://github.com/besser82/libxcrypt/issues/24
+ filter-flags -flto=* -flto
+
multibuild_foreach_variant multilib-minimal_src_configure
}