summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2024-05-29 11:26:08 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2024-05-29 11:26:46 -0700
commitdd16e702c386875ce9a634d2aa4e4efadc4627c8 (patch)
treebb568b122868b2ea1c71b9971f3c937eceaf6ccb /sys-process/parallel
parentsys-power/nut: fix newdoc bug introduced in d20e5788358b90edc2545386d07049816... (diff)
downloadgentoo-dd16e702c386875ce9a634d2aa4e4efadc4627c8.tar.gz
gentoo-dd16e702c386875ce9a634d2aa4e4efadc4627c8.tar.bz2
gentoo-dd16e702c386875ce9a634d2aa4e4efadc4627c8.zip
sys-process/parallel: bump to 20240522
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'sys-process/parallel')
-rw-r--r--sys-process/parallel/Manifest2
-rw-r--r--sys-process/parallel/parallel-20240522.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-process/parallel/Manifest b/sys-process/parallel/Manifest
index ba30f9b1f36a..20db08cc4997 100644
--- a/sys-process/parallel/Manifest
+++ b/sys-process/parallel/Manifest
@@ -1,2 +1,4 @@
DIST parallel-20240222.tar.bz2 2570609 BLAKE2B 79a2b2810601b2613555ef76124b250ed0b614da30cfe250c0c4cfa578948bfaabce93cda0dcfff3d43cdf520b12f13b5569347569d95dbd3574b5e4aac411e2 SHA512 afbee9496e48ba4089b7f5ce5115d02d4e609d8f48ee2f715bbef62bda8b429da65d1457880d707d1f43482e751c75f5ede52489abed29ef8c110c55132fc547
DIST parallel-20240222.tar.bz2.sig 2080 BLAKE2B 982d4ea8c513f972905fdae6adebc3fb5756898f6fcd65563c87b3484bffec4a0ef3660265b2df343b4437c6930918101c886014c3332e30c9bac03031ccd471 SHA512 527bfc24ef29f60894538890d16bbff53c1df44b8d1a51750ec2f19207bbe66bddd19f6c4fb2e4778ed4f0166405c87769ee2681490b3ffa8cc627d8c33da810
+DIST parallel-20240522.tar.bz2 2571391 BLAKE2B 50a6b41959ac06d92dc7f10492a7c758504bfb2686d2cfb8c6092f8e6a272abaaa6e40d209b48e8dcfef42460fdffd31d7e0d789591b347bcaa5ca22a5ac58a9 SHA512 22156c2ba722696e8f85efcc5996e6811523c2545d8a3daf328801f09b1edb9665172ddce2cf738d1c6af87ac9da0268ec1e4b07178f81c4bea27f3903d78bfd
+DIST parallel-20240522.tar.bz2.sig 2080 BLAKE2B 6b74a8487f5cb2400d0e81743007983e3d9ed7449ff0f05d1ca62dcc718dc8a843de414805c68776e2705264f59076ac756d3058c67ff666f11d4d3c4fdbf6dc SHA512 edd6624de644d751f44f51bc9b1b502032e9ee9d6085ad81a6cf7288d045ea69295908fc2d3c3da2b3bd0eeef922c5a27d746b9688ea700d4af7b1fb8893f62c
diff --git a/sys-process/parallel/parallel-20240522.ebuild b/sys-process/parallel/parallel-20240522.ebuild
new file mode 100644
index 000000000000..fd04358e548a
--- /dev/null
+++ b/sys-process/parallel/parallel-20240522.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/oletange.asc
+inherit verify-sig
+
+DESCRIPTION="A shell tool for executing jobs in parallel locally or on remote machines"
+HOMEPAGE="https://www.gnu.org/software/parallel/ https://git.savannah.gnu.org/cgit/parallel.git/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+SRC_URI+=" verify-sig? ( mirror://gnu/${PN}/${P}.tar.bz2.sig )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Devel-Size
+ dev-perl/Text-CSV
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ virtual/perl-IO
+"
+DEPEND="${RDEPEND}"
+BDEPEND="verify-sig? ( >=sec-keys/openpgp-keys-oletange-20210423 )"
+
+src_configure() {
+ # bug #908214
+ unset PARALLEL_HOME
+
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_compile() {
+ # Silence a warning where it tries to use pod2pdf; force it to fallback
+ # to pre-generated PDF.
+ mkdir "${T}"/fake || die
+ ln -s "${BROOT}"/bin/false "${T}"/fake/pod2pdf || die
+ export PATH="${T}/fake:${PATH}"
+
+ default
+}