summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-18 07:09:21 +0000
committerSam James <sam@gentoo.org>2023-12-18 07:09:21 +0000
commit727a16cedb529b0225b5847082bcbd4f72c3380f (patch)
tree92074663847fed6ca2f8e0839ac00f0328c2b562 /sys-process
parentdev-ruby/rcairo: add 1.17.13 (diff)
downloadgentoo-727a16cedb529b0225b5847082bcbd4f72c3380f.tar.gz
gentoo-727a16cedb529b0225b5847082bcbd4f72c3380f.tar.bz2
gentoo-727a16cedb529b0225b5847082bcbd4f72c3380f.zip
sys-process/htop: drop stale Python usage
Thanks to parona for pointing this out, it was dropped upstream in a852fae8e02650d621abdd5aea29b7a56d9a3090 [0] [0] https://github.com/htop-dev/htop/commit/a852fae8e02650d621abdd5aea29b7a56d9a3090 Closes: https://bugs.gentoo.org/919913 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/htop/htop-3.2.2.ebuild12
-rw-r--r--sys-process/htop/htop-9999.ebuild12
2 files changed, 4 insertions, 20 deletions
diff --git a/sys-process/htop/htop-3.2.2.ebuild b/sys-process/htop/htop-3.2.2.ebuild
index 3d2a6b0bdd42..6000d7d45005 100644
--- a/sys-process/htop/htop-3.2.2.ebuild
+++ b/sys-process/htop/htop-3.2.2.ebuild
@@ -3,11 +3,9 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
-
# We avoid xdg.eclass here because it'll pull in glib, desktop utils on
# htop which is often used on headless machines. bug #787470
-inherit linux-info optfeature python-any-r1 xdg-utils
+inherit linux-info optfeature xdg-utils
DESCRIPTION="Interactive process viewer"
HOMEPAGE="https://htop.dev/ https://github.com/htop-dev/htop"
@@ -39,18 +37,12 @@ RDEPEND="
)
"
DEPEND="${RDEPEND}"
-BDEPEND="${PYTHON_DEPS}
- virtual/pkgconfig"
+BDEPEND="virtual/pkgconfig"
DOCS=( ChangeLog README )
CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"
-pkg_setup() {
- python-any-r1_pkg_setup
- linux-info_pkg_setup
-}
-
src_prepare() {
default
diff --git a/sys-process/htop/htop-9999.ebuild b/sys-process/htop/htop-9999.ebuild
index 308bba2b8c3c..95b4f940ef01 100644
--- a/sys-process/htop/htop-9999.ebuild
+++ b/sys-process/htop/htop-9999.ebuild
@@ -3,11 +3,9 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
-
# We avoid xdg.eclass here because it'll pull in glib, desktop utils on
# htop which is often used on headless machines. bug #787470
-inherit linux-info optfeature python-any-r1 xdg-utils
+inherit linux-info optfeature xdg-utils
DESCRIPTION="Interactive process viewer"
HOMEPAGE="https://htop.dev/ https://github.com/htop-dev/htop"
@@ -39,18 +37,12 @@ RDEPEND="
)
"
DEPEND="${RDEPEND}"
-BDEPEND="${PYTHON_DEPS}
- virtual/pkgconfig"
+BDEPEND="virtual/pkgconfig"
DOCS=( ChangeLog README )
CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"
-pkg_setup() {
- python-any-r1_pkg_setup
- linux-info_pkg_setup
-}
-
src_prepare() {
default