summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_authn_sasl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_authn_sasl')
-rw-r--r--www-apache/mod_authn_sasl/Manifest1
-rw-r--r--www-apache/mod_authn_sasl/files/10_mod_authn_sasl.conf5
-rw-r--r--www-apache/mod_authn_sasl/metadata.xml5
-rw-r--r--www-apache/mod_authn_sasl/mod_authn_sasl-1.2.ebuild27
4 files changed, 38 insertions, 0 deletions
diff --git a/www-apache/mod_authn_sasl/Manifest b/www-apache/mod_authn_sasl/Manifest
new file mode 100644
index 000000000000..2da77b9db5a1
--- /dev/null
+++ b/www-apache/mod_authn_sasl/Manifest
@@ -0,0 +1 @@
+DIST mod_authn_sasl-1.2.tar.bz2 274790 SHA256 4329e1f429560041cebe67b74a588330f382759bcbb91d3e4145b18e59734b57 SHA512 cc967d350c7110f98b56fa94244473dd2cfc813e7992d7aa8a0ae2219264834b1e2218a1f0982bad661e335bfd713cfb9e8efa6ab69f07a309370e4b7d74ef02 WHIRLPOOL e906277df03d5027f9911d62f47d06ecff0bdb4a230b326c0d4361129bdf0358fd665c2e4c9b1ed54f79aa51fc02bae1edde4132369dee897c5ef86bd49e9fe8
diff --git a/www-apache/mod_authn_sasl/files/10_mod_authn_sasl.conf b/www-apache/mod_authn_sasl/files/10_mod_authn_sasl.conf
new file mode 100644
index 000000000000..05f71c156e41
--- /dev/null
+++ b/www-apache/mod_authn_sasl/files/10_mod_authn_sasl.conf
@@ -0,0 +1,5 @@
+<IfDefine AUTHN_SASL>
+LoadModule authn_sasl_module modules/mod_authn_sasl.so
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_authn_sasl/metadata.xml b/www-apache/mod_authn_sasl/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/www-apache/mod_authn_sasl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_authn_sasl/mod_authn_sasl-1.2.ebuild b/www-apache/mod_authn_sasl/mod_authn_sasl-1.2.ebuild
new file mode 100644
index 000000000000..7d038d1a0ab4
--- /dev/null
+++ b/www-apache/mod_authn_sasl/mod_authn_sasl-1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils apache-module
+
+DESCRIPTION="Cyrus SASL authentication module for Apache"
+HOMEPAGE="http://mod-authn-sasl.sourceforge.net/"
+SRC_URI="http://downloads.sourceforge.net/project/mod-authn-sasl/mod-authn-sasl/${PV}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="dev-libs/cyrus-sasl"
+RDEPEND="${DEPEND}"
+
+APXS2_ARGS="-c ${PN}.c -lsasl2"
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="AUTHN_SASL"
+
+need_apache2
+
+src_install() {
+ apache-module_src_install
+}