summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-01-10 11:19:01 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2021-01-10 11:19:27 +0100
commit70f9a91afcff4f8d5aa14368774de21c58076cb4 (patch)
treeb07a1f88d56ec273ec21468d2d437db065e5db5b /www-apps/postfixadmin
parentsys-devel/binutils-apple-8.2.1-r100: drop non-TAPI version (diff)
downloadgentoo-70f9a91afcff4f8d5aa14368774de21c58076cb4.tar.gz
gentoo-70f9a91afcff4f8d5aa14368774de21c58076cb4.tar.bz2
gentoo-70f9a91afcff4f8d5aa14368774de21c58076cb4.zip
www-apps/postfixadmin: bump to 3.3.0
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'www-apps/postfixadmin')
-rw-r--r--www-apps/postfixadmin/Manifest1
-rw-r--r--www-apps/postfixadmin/postfixadmin-3.3.0.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/www-apps/postfixadmin/Manifest b/www-apps/postfixadmin/Manifest
index 56aef54dbbfa..cd477300fbd9 100644
--- a/www-apps/postfixadmin/Manifest
+++ b/www-apps/postfixadmin/Manifest
@@ -1,2 +1,3 @@
DIST postfixadmin-3.2.3.tar.gz 1330423 BLAKE2B 95aeb1a5f3b1dca2ce60e3e6a974f59b8c0e649c185149adb5d1259477cfe113b59c06f825cc9e1a38741260f111eaa3eef5a26ca44260aea2277b16f1f54543 SHA512 d44addb9a3ca830caf55b603363054df561d659957f21cab7523465ebf02ca18abe7fcf298fe718d957d0b7bf5613e2dde69c78c26e0f7f6f595d79b28fe08ab
DIST postfixadmin-3.2.4.tar.gz 1331185 BLAKE2B a16df15f6376f9024114c5870174168e5f3d4b0f52d8759db0d83cb4c05fbbe2949056de0ca5ce097652588b777d59f08bcc2555577c95fbd7f2ebc5dd7f357f SHA512 2bd7ae05addbaf3c6c7eebea16ec1e21b2c67c8e6161446ed82a9553c26c04e19c1ec9ce248a9b9df504df56d309590259e6f04907b04b593548028b40e40d47
+DIST postfixadmin-3.3.0.tar.gz 1850601 BLAKE2B 126a9ad89338372ff28f7d4400456678d6599f453457e180b31e34dd3239023c0c77f3d195ff25dbebfbe3fd65186934ac876d92b438c885340c34eba28cf93f SHA512 941c1b51d353253039fd8af48428b981e5f79f463ed09e5bb3417a22cbd114e025f86245e74c92ff5e375ab944ed7d9ff57f51d145838eede77ab3f7e54d5eb6
diff --git a/www-apps/postfixadmin/postfixadmin-3.3.0.ebuild b/www-apps/postfixadmin/postfixadmin-3.3.0.ebuild
new file mode 100644
index 000000000000..0df1b6d26679
--- /dev/null
+++ b/www-apps/postfixadmin/postfixadmin-3.3.0.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit user webapp
+
+DESCRIPTION="Web Based Management tool for Postfix style virtual domains and users"
+HOMEPAGE="http://postfixadmin.sourceforge.net"
+SRC_URI="https://github.com/postfixadmin/postfixadmin/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+mysql postgres +vacation"
+REQUIRED_USE="|| ( mysql postgres )"
+
+DEPEND="
+ dev-lang/php:*[unicode,imap,postgres?]
+ vacation? (
+ dev-perl/DBI
+ dev-perl/Email-Sender
+ dev-perl/Email-Valid
+ dev-perl/Log-Dispatch
+ dev-perl/Log-Log4perl
+ dev-perl/MIME-Charset
+ dev-perl/MIME-EncWords
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )
+ )
+"
+RDEPEND="${DEPEND}
+ virtual/httpd-php
+ mysql? ( || ( dev-lang/php[mysqli] dev-lang/php[mysql] ) )"
+
+S="${WORKDIR}/${PN}-${P}"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if use vacation; then
+ enewgroup vacation
+ enewuser vacation -1 -1 -1 vacation
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ if use vacation; then
+ insinto /var/spool/vacation
+ newins VIRTUAL_VACATION/vacation.pl vacation.pl-${SLOT}
+ fowners vacation:vacation /var/spool/vacation/vacation.pl-${SLOT}
+ fperms 770 /var/spool/vacation/vacation.pl-${SLOT}
+ dodoc VIRTUAL_VACATION/FILTER_README
+ newdoc VIRTUAL_VACATION/INSTALL.md VIRTUAL_VACATION_INSTALL.md
+ rm -r VIRTUAL_VACATION/{vacation.pl,INSTALL.md,tests,FILTER_README} || die
+ fi
+
+ docinto /usr/share/doc/${PF}/
+ dodoc -r ADDITIONS
+
+ local docs="DOCUMENTS/*.txt INSTALL.TXT CHANGELOG.TXT"
+ dodoc ${docs}
+
+ rm -rf ${docs} DOCUMENTS/ GPL-LICENSE.TXT LICENSE.TXT debian/ tests/ ADDITIONS/
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.inc.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-2.3.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ einfo "Please note that if upgrading from version prior to 3.3.0,"
+ einfo "existing setup_password will no longer work and you will"
+ einfo "need to generate new one. See instructions in setup.php."
+
+ if use vacation; then
+ # portage does not update owners of directories (feature :)
+ chown vacation:vacation "${ROOT}"/var/spool/vacation/
+ einfo
+ einfo "/var/spool/vacation/vacation.pl symlink was updated to:"
+ einfo "/var/spool/vacation/vacation.pl-${SLOT}"
+ ln -sf "${ROOT}"/var/spool/vacation/vacation.pl{-${SLOT},} || die
+ fi
+}
+
+pkg_postrm() {
+ # Make sure we don't leave broken vacation.pl symlink
+ find -L "${ROOT}"/var/spool/vacation/ -type l -delete
+ local shopt_save=$(shopt -p nullglob)
+ shopt -s nullglob
+ local vacation=( "${ROOT}"/var/spool/vacation/vacation.pl-* )
+ ${shopt_save}
+ if [[ ! -e "${ROOT}"/var/spool/vacation/vacation.pl && -n ${vacation[@]} ]]; then
+ ln -s "${vacation[-1]}" "${ROOT}"/var/spool/vacation/vacation.pl || die
+ ewarn "/var/spool/vacation/vacation.pl was updated to point on most"
+ ewarn "recent verion, but please, do your own checks"
+ fi
+}