summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-10-13 08:41:32 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-10-13 08:42:29 +0300
commit1a5e0b5249ded9d433cf3dcbe021cb69adb9f436 (patch)
tree8a1e6b3a0281db695c1c541c4391b15b864cf3f3 /www-apps/wordpress
parentdev-ruby/bigdecimal: drop 3.1.4 (diff)
downloadgentoo-1a5e0b5249ded9d433cf3dcbe021cb69adb9f436.tar.gz
gentoo-1a5e0b5249ded9d433cf3dcbe021cb69adb9f436.tar.bz2
gentoo-1a5e0b5249ded9d433cf3dcbe021cb69adb9f436.zip
www-apps/wordpress: add 6.3.2
Security update. Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps/wordpress')
-rw-r--r--www-apps/wordpress/Manifest1
-rw-r--r--www-apps/wordpress/wordpress-6.3.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/www-apps/wordpress/Manifest b/www-apps/wordpress/Manifest
index b7ff3156a01b..8e668dbc3c8d 100644
--- a/www-apps/wordpress/Manifest
+++ b/www-apps/wordpress/Manifest
@@ -1 +1,2 @@
DIST wordpress-6.3.1.tar.gz 23447259 BLAKE2B 081662cab27632410b69cfbae6dad8e14119125f0fcaecf7b48c3d53659996569fd742b181daf2ef8aabcd5a8fe1487aec5e6934c017aa2298db74e1df820d44 SHA512 786abd032f2c245f2af4974a3b11cfbc541754a12cbb1bfa2339ab68b469711d5d8bf9394ff12fd7b6b7a5b4006d72aeecd34dc8fbed531b39df287e878e2da9
+DIST wordpress-6.3.2.tar.gz 23465047 BLAKE2B d1fe6e7822394051dab99bd854095429ae115f6c41a558805276c8c7a5440e8279ae3ca89f5b2da789550bc0d40ecab44000de8e39a753fa1b3a01f4c8e6194f SHA512 68fade6d608b8be4f35c7b7d0e8d73658b8690f3548d5374ca8a16a7b18affb9bcea54c1357fb442a1928cc0826ab40cabfd6ad91f0b4a5c00451036bea78747
diff --git a/www-apps/wordpress/wordpress-6.3.2.ebuild b/www-apps/wordpress/wordpress-6.3.2.ebuild
new file mode 100644
index 000000000000..b6c209d75a8c
--- /dev/null
+++ b/www-apps/wordpress/wordpress-6.3.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="Wordpress PHP and MySQL based content management system (CMS)"
+HOMEPAGE="https://wordpress.org/"
+SRC_URI="https://wordpress.org/${P/_rc/-RC}.tar.gz"
+S=${WORKDIR}/${PN}
+
+LICENSE="GPL-2+"
+if [[ ${PV} != *_rc* ]]; then
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+RDEPEND="virtual/httpd-php
+ || ( dev-lang/php[mysql] dev-lang/php[mysqli] )"
+
+need_httpd_cgi
+
+IUSE="+akismet examples +themes vhosts"
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc readme.html
+ rm readme.html license.txt || die
+
+ if use !akismet ; then
+ rm -R wp-content/plugins/akismet/ || die
+ fi
+ if use !examples ; then
+ rm wp-content/plugins/hello.php || die
+ fi
+ if use !themes ; then
+ rm -R wp-content/themes/*/ || die
+ fi
+
+ [[ -f wp-config.php ]] || cp wp-config-sample.php wp-config.php
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/index.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/menu.php
+ webapp_serverowned "${MY_HTDOCSDIR}"
+ # allows plugins update if allowed within WP
+ webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/includes/file.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/wp-config.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
+
+ webapp_src_install
+}