summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-30 23:59:48 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:30:21 +0100
commit0147ec1da1a0891f5d72d1d89ce55567c31ed3be (patch)
tree86592f974b4a3328c4cdd6e58e624cdf4d6e2ca5 /www-servers
parentwww-servers/lighttpd: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-0147ec1da1a0891f5d72d1d89ce55567c31ed3be.tar.gz
gentoo-0147ec1da1a0891f5d72d1d89ce55567c31ed3be.tar.bz2
gentoo-0147ec1da1a0891f5d72d1d89ce55567c31ed3be.zip
www-servers/lighttpd: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/lighttpd/lighttpd-1.4.58-r1.ebuild2
-rw-r--r--www-servers/lighttpd/lighttpd-1.4.59-r1.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/www-servers/lighttpd/lighttpd-1.4.58-r1.ebuild b/www-servers/lighttpd/lighttpd-1.4.58-r1.ebuild
index ced96c23fec4..957835c1132b 100644
--- a/www-servers/lighttpd/lighttpd-1.4.58-r1.ebuild
+++ b/www-servers/lighttpd/lighttpd-1.4.58-r1.ebuild
@@ -229,6 +229,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+
use ipv6 && readme.gentoo_print_elog
if [[ -f ${ROOT}/etc/conf.d/spawn-fcgi.conf ]] ; then
diff --git a/www-servers/lighttpd/lighttpd-1.4.59-r1.ebuild b/www-servers/lighttpd/lighttpd-1.4.59-r1.ebuild
index 0ad33eb525b3..6c00dcca0b4f 100644
--- a/www-servers/lighttpd/lighttpd-1.4.59-r1.ebuild
+++ b/www-servers/lighttpd/lighttpd-1.4.59-r1.ebuild
@@ -209,6 +209,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+
if use ipv6; then readme.gentoo_print_elog; fi
if [[ -f ${ROOT}/etc/lighttpd.conf ]] ; then