summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-03 19:36:46 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-03 19:36:53 -0700
commit9e4561bd2aabc10a6053d9cfdf4c9f14fa9e4ca7 (patch)
tree372c867c5ea06359a604955edd69fa4f10a49bcf /x11-apps/xsm/xsm-1.0.5.ebuild
parentx11-apps/xlsfonts: Version bump to 1.0.7 (diff)
downloadgentoo-9e4561bd2aabc10a6053d9cfdf4c9f14fa9e4ca7.tar.gz
gentoo-9e4561bd2aabc10a6053d9cfdf4c9f14fa9e4ca7.tar.bz2
gentoo-9e4561bd2aabc10a6053d9cfdf4c9f14fa9e4ca7.zip
x11-apps/xsm: Version bump to 1.0.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps/xsm/xsm-1.0.5.ebuild')
-rw-r--r--x11-apps/xsm/xsm-1.0.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-apps/xsm/xsm-1.0.5.ebuild b/x11-apps/xsm/xsm-1.0.5.ebuild
new file mode 100644
index 000000000000..22022dd49fb0
--- /dev/null
+++ b/x11-apps/xsm/xsm-1.0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X Session Manager"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="x11-libs/libXaw
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libICE
+ x11-libs/libSM"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+pkg_setup() {
+ # (#158056) /usr/$(get_libdir)/X11/xsm could be a symlink
+ local XSMPATH="${EROOT}/usr/$(get_libdir)/X11/xsm"
+ if [[ -L ${XSMPATH} ]]; then
+ einfo "Removing symlink ${XSMPATH}"
+ rm -f ${XSMPATH} || die "failed to remove symlink ${XSMPATH}"
+ fi
+ xorg-3_pkg_setup
+}