summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-15 22:07:06 +0000
committerSam James <sam@gentoo.org>2021-03-15 22:07:06 +0000
commite3180b3b7613bf08d6c4751bc6ef0efbb7ea90c1 (patch)
treebb125794b4e745d581089ee9179ba8aa08461daf /x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.20.ebuild
parentx11-misc/trayer-srg: drop 1.1.7 (diff)
downloadgentoo-e3180b3b7613bf08d6c4751bc6ef0efbb7ea90c1.tar.gz
gentoo-e3180b3b7613bf08d6c4751bc6ef0efbb7ea90c1.tar.bz2
gentoo-e3180b3b7613bf08d6c4751bc6ef0efbb7ea90c1.zip
x11-libs/c++-gtk-utils: add 2.2.20
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.20.ebuild')
-rw-r--r--x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.20.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.20.ebuild b/x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.20.ebuild
new file mode 100644
index 000000000000..40a1c6ed5a62
--- /dev/null
+++ b/x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.20.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit virtualx
+
+DESCRIPTION="A number of classes and functions for programming GTK+ programs using C++"
+HOMEPAGE="http://cxx-gtk-utils.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN/++/xx}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+gtk nls"
+
+RDEPEND="
+ dev-libs/glib:2
+ gtk? ( x11-libs/gtk+:3 )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --without-guile \
+ $(use_enable nls) \
+ $(use_with gtk)
+}
+
+src_test() {
+ virtx default
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}