summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-30 19:38:13 +0100
committerSam James <sam@gentoo.org>2021-06-30 19:38:13 +0100
commited8887d47b6d3619c8efade80333f701578cc8b5 (patch)
tree7a7788548ec068708f81eac7f55f211bc02ba8c6 /x11-misc/alock
parentx11-misc/slock: fix library include/search paths, missing libcrypt dependency (diff)
downloadgentoo-ed8887d47b6d3619c8efade80333f701578cc8b5.tar.gz
gentoo-ed8887d47b6d3619c8efade80333f701578cc8b5.tar.bz2
gentoo-ed8887d47b6d3619c8efade80333f701578cc8b5.zip
x11-misc/alock: add missing libcrypt dependency
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/alock')
-rw-r--r--x11-misc/alock/alock-1.0.0-r1.ebuild (renamed from x11-misc/alock/alock-1.0.0.ebuild)13
-rw-r--r--x11-misc/alock/files/implicit_pointer_conversion_fix_amd64.patch6
2 files changed, 10 insertions, 9 deletions
diff --git a/x11-misc/alock/alock-1.0.0.ebuild b/x11-misc/alock/alock-1.0.0-r1.ebuild
index e636eb5415e6..33a86aadaf0a 100644
--- a/x11-misc/alock/alock-1.0.0.ebuild
+++ b/x11-misc/alock/alock-1.0.0-r1.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit toolchain-funcs
-# we need this since there are no tagged releases yet
+# We need this since there are no tagged releases yet
DESCRIPTION="locks the local X display until a password is entered"
HOMEPAGE="https://darkshed.net/projects/alock
https://github.com/mgumz/alock"
@@ -15,15 +16,16 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="doc imlib pam"
-DEPEND="x11-libs/libX11
+DEPEND="virtual/libcrypt:=
+ x11-libs/libX11
x11-libs/libXext
x11-libs/libXpm
x11-libs/libXrender
x11-libs/libXcursor
imlib? ( media-libs/imlib2[X] )
- pam? ( sys-libs/pam )
- doc? ( app-text/asciidoc )"
+ pam? ( sys-libs/pam )"
RDEPEND="${DEPEND}"
+BDEPEND="doc? ( app-text/asciidoc )"
PATCHES=(
"${FILESDIR}"/implicit_pointer_conversion_fix_amd64.patch
@@ -51,6 +53,7 @@ src_compile() {
src_install() {
dobin src/alock
+
if use doc; then
# We need to generate the manpage...
a2x -d manpage -f manpage ./"${PN}".txt || die "a2x conversion failed."
diff --git a/x11-misc/alock/files/implicit_pointer_conversion_fix_amd64.patch b/x11-misc/alock/files/implicit_pointer_conversion_fix_amd64.patch
index 1184ee73a612..b3172aa61841 100644
--- a/x11-misc/alock/files/implicit_pointer_conversion_fix_amd64.patch
+++ b/x11-misc/alock/files/implicit_pointer_conversion_fix_amd64.patch
@@ -1,7 +1,5 @@
-Index: alock-svn-94/src/auth_passwd.c
-===================================================================
---- alock-svn-94.orig/src/auth_passwd.c
-+++ alock-svn-94/src/auth_passwd.c
+--- a/src/auth_passwd.c
++++ b/src/auth_passwd.c
@@ -43,7 +43,7 @@
\* ---------------------------------------------------------------- */