summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-10-31 23:29:58 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-10-31 23:29:58 +0100
commit29ca21254bac80a023a11a51e61d029853fc4587 (patch)
tree73aef7b8adb1f62f200fdc26c40b866d0183ecb0 /x11-misc/flow-pomodoro/files
parentapp-emulation/docker: 1.12.3 version bump (diff)
downloadgentoo-29ca21254bac80a023a11a51e61d029853fc4587.tar.gz
gentoo-29ca21254bac80a023a11a51e61d029853fc4587.tar.bz2
gentoo-29ca21254bac80a023a11a51e61d029853fc4587.zip
x11-misc/flow-pomodoro: Version bump to 1.1.2
Package-Manager: portage-2.3.2
Diffstat (limited to 'x11-misc/flow-pomodoro/files')
-rw-r--r--x11-misc/flow-pomodoro/files/flow-pomodoro-1.1.2-compiler.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-misc/flow-pomodoro/files/flow-pomodoro-1.1.2-compiler.patch b/x11-misc/flow-pomodoro/files/flow-pomodoro-1.1.2-compiler.patch
new file mode 100644
index 000000000000..e15e32faa9a1
--- /dev/null
+++ b/x11-misc/flow-pomodoro/files/flow-pomodoro-1.1.2-compiler.patch
@@ -0,0 +1,30 @@
+From 42022f4989958d87e27d2dd5029d5cf8d0a42efa Mon Sep 17 00:00:00 2001
+From: Sergio Martins <iamsergio@gmail.com>
+Date: Sun, 30 Oct 2016 22:50:47 +0000
+Subject: [PATCH] Fix build with older gcc compilers
+
+---
+ CMakeLists.txt | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 010333f..06a4a77 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -14,6 +14,16 @@ include_directories(${Qt5Gui_INCLUDES})
+
+ set(CMAKE_CXX_FLAGS "${Qt5Gui_EXECUTABLE_COMPILE_FLAGS}")
+
++include(CheckCXXCompilerFlag)
++CHECK_CXX_COMPILER_FLAG("-std=c++11" COMPILER_SUPPORTS_CXX11)
++CHECK_CXX_COMPILER_FLAG("-std=c++0x" COMPILER_SUPPORTS_CXX0X)
++if(COMPILER_SUPPORTS_CXX11)
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
++elseif(COMPILER_SUPPORTS_CXX0X)
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
++else()
++ message(STATUS "The compiler ${CMAKE_CXX_COMPILER} has no C++11 support. Please use a different C++ compiler.")
++endif()
+
+ add_subdirectory(src)
+ add_subdirectory(plugins)