summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/i3lock
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/i3lock')
-rw-r--r--x11-misc/i3lock/Manifest3
-rw-r--r--x11-misc/i3lock/i3lock-2.5.ebuild40
-rw-r--r--x11-misc/i3lock/i3lock-2.6.ebuild40
-rw-r--r--x11-misc/i3lock/i3lock-2.7.ebuild40
-rw-r--r--x11-misc/i3lock/metadata.xml9
5 files changed, 132 insertions, 0 deletions
diff --git a/x11-misc/i3lock/Manifest b/x11-misc/i3lock/Manifest
new file mode 100644
index 000000000000..4e45bb60224b
--- /dev/null
+++ b/x11-misc/i3lock/Manifest
@@ -0,0 +1,3 @@
+DIST i3lock-2.5.tar.bz2 16135 SHA256 ac2772c9e4fc13adb882cacaae13ccc381d6d4f154ffd538634a58e6369d0d77 SHA512 8e49c25b0efe3836a8daa4dae61354ecb57374a8de8f10b8b5f262d7c1f6070d60e3ac25112be6079a56baa83f73c3c2a85d48ab27c8559df8aef358ffdab2a7 WHIRLPOOL 3adf11ecd931f1d266a56ac7d3135317d6c12c03478ae65221e985b1b8991ddac3066221d711b3f77b2ae812f1a1c74790876ced9c1f3910feae70815392c573
+DIST i3lock-2.6.tar.bz2 17972 SHA256 c02d899fefc66bc36e47b305251363861400541f3925a21a94c66cee9055402a SHA512 ccaf336b4abd65df24ba37613ba46e129d6e4c42cb8c0a05cc8d9cc0815f0f9f03613230b1cdbb5d16d6903a57a04f2c6b0fc168881ae03000aa170716fedf4a WHIRLPOOL 7ce2dfc29e3366075597097d53c09373677019d0c6f8e872a157a8e7f32b44daf0ccd19fe56c69ca8ae43f60a2d87eed4c8e2e5716cc8ec24c82f5a0cda8a2a5
+DIST i3lock-2.7.tar.bz2 19490 SHA256 6882183ed0eca439e3ad1ae3e9d48b4d0a0b6f075e3850b46bf84aec97538fe2 SHA512 7945d142d239fe7f8985c1000e22db0532456939e65ee855f12e364092808d0cc09cc818b1189e32d88c872ce00033c41c8ebefe62349630872815adaf8b3899 WHIRLPOOL 088fe683f723a6adfb6f60efb4a8f62870b96adf3a96606e9cba642f21ecf42f1fdc0b8346dd4a84a5f65bc6f5e2d1f256e80a0ba736dc4fe276a697c347c983
diff --git a/x11-misc/i3lock/i3lock-2.5.ebuild b/x11-misc/i3lock/i3lock-2.5.ebuild
new file mode 100644
index 000000000000..2b503ed1ea74
--- /dev/null
+++ b/x11-misc/i3lock/i3lock-2.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple screen locker"
+HOMEPAGE="http://i3wm.org/i3lock/"
+SRC_URI="http://i3wm.org/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="virtual/pam
+ dev-libs/libev
+ >=x11-libs/libxkbcommon-0.3.1
+ x11-libs/libxkbfile
+ x11-libs/xcb-util
+ x11-libs/libX11
+ x11-libs/cairo[xcb]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+DOCS=( CHANGELOG README )
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ sed -i -e 's:login:system-auth:' ${PN}.pam || die
+}
+
+src_install() {
+ default
+ doman ${PN}.1
+}
diff --git a/x11-misc/i3lock/i3lock-2.6.ebuild b/x11-misc/i3lock/i3lock-2.6.ebuild
new file mode 100644
index 000000000000..11787237b70e
--- /dev/null
+++ b/x11-misc/i3lock/i3lock-2.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Simple screen locker"
+HOMEPAGE="http://i3wm.org/i3lock/"
+SRC_URI="http://i3wm.org/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/pam
+ dev-libs/libev
+ >=x11-libs/libxkbcommon-0.3.1[X]
+ x11-libs/libxcb[xkb]
+ x11-libs/xcb-util
+ x11-libs/cairo[xcb]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+DOCS=( CHANGELOG README )
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ sed -i -e 's:login:system-auth:' ${PN}.pam || die
+ epatch_user
+}
+
+src_install() {
+ default
+ doman ${PN}.1
+}
diff --git a/x11-misc/i3lock/i3lock-2.7.ebuild b/x11-misc/i3lock/i3lock-2.7.ebuild
new file mode 100644
index 000000000000..6207486dcf63
--- /dev/null
+++ b/x11-misc/i3lock/i3lock-2.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Simple screen locker"
+HOMEPAGE="http://i3wm.org/i3lock/"
+SRC_URI="http://i3wm.org/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/pam
+ dev-libs/libev
+ >=x11-libs/libxkbcommon-0.5.0[X]
+ x11-libs/libxcb[xkb]
+ x11-libs/xcb-util
+ x11-libs/cairo[xcb]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+DOCS=( CHANGELOG README.md )
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ sed -i -e 's:login:system-auth:' ${PN}.pam || die
+ epatch_user
+}
+
+src_install() {
+ default
+ doman ${PN}.1
+}
diff --git a/x11-misc/i3lock/metadata.xml b/x11-misc/i3lock/metadata.xml
new file mode 100644
index 000000000000..b5caab41c7b2
--- /dev/null
+++ b/x11-misc/i3lock/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <maintainer>
+ <email>xarthisius@gentoo.org</email>
+ <name>Kacper Kowalik</name>
+ </maintainer>
+</pkgmetadata>