summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-07-20 09:57:06 +0200
committerPacho Ramos <pacho@gentoo.org>2023-07-20 09:57:55 +0200
commit3d4ee6df7da724f30f8e3ba8807584dada52e1cf (patch)
treef603b05e1b68a15541012a770a86621adbb5d66a /x11-misc/meteo
parentnet-im/sendxmpp-amm: add github upstream metadata (diff)
downloadgentoo-3d4ee6df7da724f30f8e3ba8807584dada52e1cf.tar.gz
gentoo-3d4ee6df7da724f30f8e3ba8807584dada52e1cf.tar.bz2
gentoo-3d4ee6df7da724f30f8e3ba8807584dada52e1cf.zip
x11-misc/meteo: add 0.9.9.2
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-misc/meteo')
-rw-r--r--x11-misc/meteo/Manifest1
-rw-r--r--x11-misc/meteo/meteo-0.9.9.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-misc/meteo/Manifest b/x11-misc/meteo/Manifest
index f6ed738831ff..fc55cb8a38d4 100644
--- a/x11-misc/meteo/Manifest
+++ b/x11-misc/meteo/Manifest
@@ -1 +1,2 @@
DIST meteo-0.9.9.1.tar.gz 598205 BLAKE2B ac66e84a04f087cf75f9101da0c80e68c132e0e5064aec4cb2ea609e93f48a2ef3eb51266805b2547b4839c82496b470d4bb07e4fa0538e2ebc691a9491606d8 SHA512 d148393acc47dab1886a25600adb2a3e2ff5cb313c0004d50a54106c61f3cbd26ff95d526d13a77a1d33ede2622ff2ea9277a8fdc1899ebf34581a5a6b36c861
+DIST meteo-0.9.9.2.tar.bz2 609059 BLAKE2B 77557c28c755065f5b2da6cef429df96342c67217650f3ca3e5282f14c93d095b0e4c3f7b5cdfd62374f41e543cce14080d85291019e4336acc5d9f8f09e06c9 SHA512 96f05fb2b84d0be73eb26e101edf2a03345a06c79a86ec6c9f5acbe8b32e4fbaf6f4d7b59b65eb69f4db8667e1178d5641792b259cf23c46d4dcaee8a2243a5a
diff --git a/x11-misc/meteo/meteo-0.9.9.2.ebuild b/x11-misc/meteo/meteo-0.9.9.2.ebuild
new file mode 100644
index 000000000000..043a307df6fa
--- /dev/null
+++ b/x11-misc/meteo/meteo-0.9.9.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+inherit gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Forecast application using OpenWeatherMap API"
+HOMEPAGE="https://gitlab.com/bitseater/meteo"
+SRC_URI="https://gitlab.com/bitseater/meteo/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+# One test needs network (#828052), the other simply checks desktop file
+# validation, that we also test with our QA tests
+RESTRICT="test"
+
+DEPEND="
+ dev-libs/libayatana-appindicator:0
+ dev-libs/glib:2
+ dev-libs/json-glib
+ net-libs/libsoup:2.4
+ net-libs/webkit-gtk:4
+ x11-libs/gtk+:3
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+ x11-themes/hicolor-icon-theme
+"
+BDEPEND="${PYTHON_DEPS}
+ dev-libs/appstream-glib
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+src_configure() {
+ vala_setup
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dosym com.gitlab.bitseater.meteo /usr/bin/meteo
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}